aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2011-01-12 12:31:10 +0800
committerdougb <dougb@FreeBSD.org>2011-01-12 12:31:10 +0800
commitbb7bc4c3adb85e3bcc2eb209d7335cf7bf63d964 (patch)
treee0ac2bb0e76f49f0f37af99ea32322d64cb91fb8 /net-p2p
parent2cabba457903169eae321226ef1c3fb18bff4090 (diff)
downloadfreebsd-ports-gnome-bb7bc4c3adb85e3bcc2eb209d7335cf7bf63d964.tar.gz
freebsd-ports-gnome-bb7bc4c3adb85e3bcc2eb209d7335cf7bf63d964.tar.zst
freebsd-ports-gnome-bb7bc4c3adb85e3bcc2eb209d7335cf7bf63d964.zip
Add a -nox11 version of qbittorrent-26 as a slave port.
Based in part on work in the PR, but I used a different approach. PR: ports/152550 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> Feature safe: yes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/qbittorrent-26-nox11/Makefile23
-rw-r--r--net-p2p/qbittorrent-26-nox11/pkg-descr23
-rw-r--r--net-p2p/qbittorrent-26-nox11/pkg-plist1
-rw-r--r--net-p2p/qbittorrent-26/Makefile30
5 files changed, 70 insertions, 8 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 4eb6e925ffbb..aa7b8b439c6f 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -107,6 +107,7 @@
SUBDIR += py-vertex
SUBDIR += qbittorrent-23
SUBDIR += qbittorrent-26
+ SUBDIR += qbittorrent-26-nox11
SUBDIR += qtella
SUBDIR += qtorrent
SUBDIR += rtgui
diff --git a/net-p2p/qbittorrent-26-nox11/Makefile b/net-p2p/qbittorrent-26-nox11/Makefile
new file mode 100644
index 000000000000..b7acc59e99cd
--- /dev/null
+++ b/net-p2p/qbittorrent-26-nox11/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: qbittorrent-nox11-26
+# Date created: 12 January 2011
+# Whom: dougb@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -nox11
+
+COMMENT= Bittorrent client using libtorrent-rasterbar, web UI version
+
+MASTERDIR= ${.CURDIR}/../qbittorrent-26
+
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+MAN1= qbittorrent-nox.1
+
+WITHOUT_NOTIFY= true
+
+QB26_NOX_SLAVE= true
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/qbittorrent-26-nox11/pkg-descr b/net-p2p/qbittorrent-26-nox11/pkg-descr
new file mode 100644
index 000000000000..d7ca6bba0c7c
--- /dev/null
+++ b/net-p2p/qbittorrent-26-nox11/pkg-descr
@@ -0,0 +1,23 @@
+qBittorrent v2 is the closest open source (GNU GPL v2 license) equivalent
+to utorrent. It is based on libtorrent-rasterbar.
+
+Features:
+
+ Remote control through a Web user interface
+ * Nearly identical to the regular UI, all in Ajax
+
+ Well-integrated and extensible Search Engine
+ Simultaneous search in most famous BitTorrent search sites
+ Per-category-specific search requests (e.g. Books, Music, Movies)
+ All Bittorrent extensions
+ * DHT, Peer Exchange, Full encryption, Magnet URI
+ Advanced control over trackers, peers and torrents
+ * Torrents queueing and prioritizing
+ * Torrent content selection and prioritizing
+ UPnP / NAT-PMP port forwarding support
+ Available in ~25 languages (Unicode support)
+ utorrent spoofing to bypass private trackers whitelisting
+ Advanced RSS support with download filters (inc. regex)
+ IP Filtering (eMule and PeerGuardian compatible)
+
+WWW: http://www.qbittorrent.org/
diff --git a/net-p2p/qbittorrent-26-nox11/pkg-plist b/net-p2p/qbittorrent-26-nox11/pkg-plist
new file mode 100644
index 000000000000..1cbfbce436ab
--- /dev/null
+++ b/net-p2p/qbittorrent-26-nox11/pkg-plist
@@ -0,0 +1 @@
+bin/qbittorrent-nox
diff --git a/net-p2p/qbittorrent-26/Makefile b/net-p2p/qbittorrent-26/Makefile
index cca5d7e0262f..cccec76d01b6 100644
--- a/net-p2p/qbittorrent-26/Makefile
+++ b/net-p2p/qbittorrent-26/Makefile
@@ -7,30 +7,39 @@
PORTNAME= qbittorrent
PORTVERSION= 2.6.1
+PORTREVISION?= 0
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PKGNAME}/
MAINTAINER= dougb@FreeBSD.org
-COMMENT= Bittorrent client using Qt4 and libtorrent-rasterbar
+COMMENT?= Bittorrent client using Qt4 and libtorrent-rasterbar
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
- torrent-rasterbar.5:${PORTSDIR}/net-p2p/libtorrent-rasterbar-14 \
- GeoIP.5:${PORTSDIR}/net/GeoIP
+ torrent-rasterbar.5:${PORTSDIR}/net-p2p/libtorrent-rasterbar-14
MAKE_JOBS_SAFE= yes
CONFLICTS= qbittorrent-2.[2345789].*
+USE_QT_VER= 4
+QT_COMPONENTS= corelib network qmake_build moc_build rcc_build
+
+.if !defined(QB26_NOX_SLAVE)
+.if defined(WITHOUT_X11)
+BROKEN= Use net-p2p/${PORTNAME}-nox11 for the non-GUI version
+.endif
+LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
OPTIONS= NOTIFY "Enable libnotify support" on
+QT_COMPONENTS+= gui xml uic_build
+INSTALLS_ICONS= yes
+.else
+CONFIGURE_ARGS+= --disable-gui
+.endif
-USE_QT_VER= 4
-QT_COMPONENTS= corelib gui network xml \
- moc_build qmake_build rcc_build uic_build
QT_NONSTANDARD= yes
HAS_CONFIGURE= yes
-INSTALLS_ICONS= yes
-MAN1= qbittorrent.1
+MAN1?= qbittorrent.1
.include <bsd.port.pre.mk>
@@ -46,6 +55,11 @@ post-patch:
@${ECHO_CMD} "LIBS+= -lexecinfo" >> ${WRKSRC}/src/src.pro
post-install:
+.if !defined(QB26_NOX_SLAVE)
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
+.else
+ @${STRIP_CMD} ${PREFIX}/bin/qbittorrent-nox
+ ${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent-nox.1 ${MANPREFIX}/man/man1
+.endif
.include <bsd.port.post.mk>