aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2006-06-30 03:06:40 +0800
committerflz <flz@FreeBSD.org>2006-06-30 03:06:40 +0800
commitcf3805cd1e18f82c9fa1fdec1b984ea6ee4f79a9 (patch)
tree59fd6f4ce28e9e997f53e1930827f8dd6f4a7b7f /net-p2p
parent1dcb96274334839567c4fc64fbfe11ad9a147628 (diff)
downloadfreebsd-ports-gnome-cf3805cd1e18f82c9fa1fdec1b984ea6ee4f79a9.tar.gz
freebsd-ports-gnome-cf3805cd1e18f82c9fa1fdec1b984ea6ee4f79a9.tar.zst
freebsd-ports-gnome-cf3805cd1e18f82c9fa1fdec1b984ea6ee4f79a9.zip
Fix build when openssl isn't installed from ports.
Reported by: krisbot and a lot of people
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 6494dbeb54ee..1e210f07e0d6 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -20,12 +20,16 @@ CONFLICTS?= libtorrent-devel-[0-9]*
USE_GCC= 3.4
USE_GNOME= pkgconfig gnomehack
+USE_OPENSSL= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-debug
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --disable-debug --with-openssl=${OPENSSLBASE}
+
post-patch:
@${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>