aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2011-08-09 13:36:48 +0800
committerdougb <dougb@FreeBSD.org>2011-08-09 13:36:48 +0800
commitdfed5b2e7a2fc992d797f43d7c54213515fa65cf (patch)
tree4925c39601444a1d8f5a72cfdb44726419912841 /net-p2p
parent800041b85458d8da221d47b3deae939d83f8926d (diff)
downloadfreebsd-ports-gnome-dfed5b2e7a2fc992d797f43d7c54213515fa65cf.tar.gz
freebsd-ports-gnome-dfed5b2e7a2fc992d797f43d7c54213515fa65cf.tar.zst
freebsd-ports-gnome-dfed5b2e7a2fc992d797f43d7c54213515fa65cf.zip
Fix handling of COMPILETIME_OPTIONS in configure. Inspired by the PR
but I used a different solution. PR: ports/155958 Submitted by: Maxim Samsonov <xors@mne.ru>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-15/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/net-p2p/libtorrent-rasterbar-15/Makefile b/net-p2p/libtorrent-rasterbar-15/Makefile
index 7134e46633b4..4344e1abb1ec 100644
--- a/net-p2p/libtorrent-rasterbar-15/Makefile
+++ b/net-p2p/libtorrent-rasterbar-15/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libtorrent-rasterbar
PORTVERSION= 0.15.7
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net-p2p ipv6
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= libtorrent
@@ -55,15 +55,18 @@ CONFIGURE_ARGS+= --enable-python-binding \
CONFIGURE_ARGS+= --disable-python-binding
.endif
-.if defined(SLAVE_PORT) && ${SLAVE_PORT:L}=="yes"
-post-patch: slave-post-patch
-.else
-post-patch:
- ${MV} ${WRKSRC}/include/libtorrent/alloca.hpp \
+pre-patch:
+ @${MV} ${WRKSRC}/include/libtorrent/alloca.hpp \
${WRKSRC}/include/libtorrent/alloca.hpp.Dist
- ${SED} -e 's#alloca.h#stdlib.h#g' \
+ @${SED} -e 's#alloca.h#stdlib.h#g' \
${WRKSRC}/include/libtorrent/alloca.hpp.Dist > \
${WRKSRC}/include/libtorrent/alloca.hpp
+ @${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Dist
+ @${SED} -e 's#COMPILETIME_OPTIONS+="#COMPILETIME_OPTIONS="$$COMPILETIME_OPTIONS #g' \
+ ${WRKSRC}/configure.Dist > ${WRKSRC}/configure
+
+.if defined(SLAVE_PORT) && ${SLAVE_PORT:L}=="yes"
+post-patch: slave-post-patch
.endif
.if defined(SLAVE_PORT) && ${SLAVE_PORT:L}=="yes"