aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-02-04 06:43:37 +0800
committernemysis <nemysis@FreeBSD.org>2014-02-04 06:43:37 +0800
commit11cad26db59aa82de87a182d1f34f4d73cfdc7e8 (patch)
tree03d220c1042c32cf9709f16a8cd947c7cac97e55 /net-p2p
parent1cefc53f11173184a20db951ed8a47a2179c4cc2 (diff)
downloadfreebsd-ports-gnome-11cad26db59aa82de87a182d1f34f4d73cfdc7e8.tar.gz
freebsd-ports-gnome-11cad26db59aa82de87a182d1f34f4d73cfdc7e8.tar.zst
freebsd-ports-gnome-11cad26db59aa82de87a182d1f34f4d73cfdc7e8.zip
net-p2p/libtorrent-rasterbar
- Change master sites, use SF instead of GOOGLE_CODE - Change license BSD to BSD3CLAUSE - Disable all warnings with -w - Set PORTSCOUT, with 0.16.14 segmentation fault with qBittorrent Versions 3.1.5, 3.1.6, 3.1.8 - Add SHLIB_VER and PLIST_SUB - Add STRIP Option, and add to default Options - Strip libraries for Master and Slave Port net-p2p/libtorrent-rasterbar-python - Add STRIP to OPTIONS_EXCLUDE
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-python/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile23
-rw-r--r--net-p2p/libtorrent-rasterbar/pkg-plist2
3 files changed, 21 insertions, 6 deletions
diff --git a/net-p2p/libtorrent-rasterbar-python/Makefile b/net-p2p/libtorrent-rasterbar-python/Makefile
index e8d51c2d0c9b..bd8edc7a22c9 100644
--- a/net-p2p/libtorrent-rasterbar-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-python/Makefile
@@ -22,7 +22,7 @@ PYDISTUTILS_PKGNAME= python_libtorrent
PLIST= ${NONEXISTENT}
PLIST_FILES= %%PYTHON_SITELIBDIR%%/libtorrent.so
-OPTIONS_EXCLUDE= DOCS EXAMPLES
+OPTIONS_EXCLUDE= DOCS EXAMPLES STRIP
# insure python paths are correctly identified
CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 570d6b86b17d..6aae1f2645cb 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -5,13 +5,12 @@ PORTNAME= libtorrent-rasterbar
PORTVERSION= 0.16.13
PORTREVISION= 2
CATEGORIES?= net-p2p ipv6
-MASTER_SITES= GOOGLE_CODE
-PROJECTHOST= libtorrent
+MASTER_SITES= SF/${PORTNAME:S/-rasterbar//}/${PORTNAME:S/-rasterbar//}/
MAINTAINER= nemysis@FreeBSD.org
COMMENT?= C++ library implementing a BitTorrent client
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LIB_DEPENDS?= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
libGeoIP.so:${PORTSDIR}/net/GeoIP
@@ -19,8 +18,12 @@ LIB_DEPENDS?= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
USES= compiler:c++11-lang pathfix pkgconfig iconv
USE_OPENSSL= yes
GNU_CONFIGURE= yes
+CFLAGS+= -w
USE_LDCONFIG= yes
+# Wrong versioning upstream
+PORTSCOUT= skipv:0.16.14
+
CONFIGURE_ARGS= --disable-debug \
--disable-static \
--enable-dht \
@@ -34,6 +37,9 @@ CONFIGURE_ARGS= --disable-debug \
--with-libiconv \
--with-openssl=${OPENSSLBASE}
+SHLIB_VER= 7
+PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
+
SUB_FILES= pkg-message
PORTDOCS= *
@@ -47,7 +53,8 @@ DOC_FILES2= *.png *.jpg *.gif *.html *.rst *.css
PORTEXAMPLES= *.cpp
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES STRIP
+OPTIONS_DEFAULT= STRIP
.include <bsd.port.options.mk>
@@ -63,6 +70,14 @@ post-patch:
${WRKSRC}/Jamfile
post-install:
+.if ${PORT_OPTIONS:MSTRIP}
+ ${STRIP_CMD} \
+ ${STAGEDIR}${PREFIX}/lib/libtorrent-rasterbar.so.${SHLIB_VER}
+.else
+ ${STRIP_CMD} \
+ ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages/libtorrent.so
+.endif
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
diff --git a/net-p2p/libtorrent-rasterbar/pkg-plist b/net-p2p/libtorrent-rasterbar/pkg-plist
index 8badb60d3957..6dbdf41fa7dc 100644
--- a/net-p2p/libtorrent-rasterbar/pkg-plist
+++ b/net-p2p/libtorrent-rasterbar/pkg-plist
@@ -135,7 +135,7 @@ include/libtorrent/web_peer_connection.hpp
include/libtorrent/xml_parse.hpp
lib/libtorrent-rasterbar.la
lib/libtorrent-rasterbar.so
-lib/libtorrent-rasterbar.so.7
+lib/libtorrent-rasterbar.so.%%SHLIB_VER%%
libdata/pkgconfig/libtorrent-rasterbar.pc
@dirrm include/libtorrent/kademlia
@dirrm include/libtorrent/extensions