aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-01-09 20:59:16 +0800
committerflz <flz@FreeBSD.org>2007-01-09 20:59:16 +0800
commit5e62d1a5178969feea55a6a8e122bf35b387822a (patch)
tree5f8c7ad33f09664f0827b57a943cc4699d4a5b7c /net-p2p
parent40991bf7e239eb8d67a176cd569118f1c9e15b75 (diff)
downloadfreebsd-ports-gnome-5e62d1a5178969feea55a6a8e122bf35b387822a.tar.gz
freebsd-ports-gnome-5e62d1a5178969feea55a6a8e122bf35b387822a.tar.zst
freebsd-ports-gnome-5e62d1a5178969feea55a6a8e122bf35b387822a.zip
Update rtorrent to 0.7.1.
Reminded by: kwm
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/Makefile10
-rw-r--r--net-p2p/rtorrent/distinfo6
-rw-r--r--net-p2p/rtorrent/files/stable-src_option__parser.cc12
3 files changed, 10 insertions, 18 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index c0d9467eabfd..5870ae660f48 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -6,15 +6,19 @@
#
PORTNAME?= rtorrent
-PORTVERSION?= 0.6.4
-PORTREVISION?= 1
+PORTVERSION?= 0.7.1
+PORTREVISION?= 0
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
MAINTAINER?= flz@FreeBSD.org
COMMENT?= BitTorrent Client written in C++
-LIB_DEPENDS?= torrent.9:${PORTSDIR}/net-p2p/libtorrent
+LIB_DEPENDS?= # empty
+
+# Libtorrent 0.11.{0,1} are both libtorrent.10, explicitely depend on 0.11.1+.
+BUILD_DEPENDS?= libtorrent-devel>=0.11.1:${PORTSDIR}/net-p2p/libtorrent-devel
+RUN_DEPENDS?= libtorrent-devel>=0.11.1:${PORTSDIR}/net-p2p/libtorrent-devel
LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
CONFLICTS?= rtorrent-devel-[0-9]*
diff --git a/net-p2p/rtorrent/distinfo b/net-p2p/rtorrent/distinfo
index 3454e3375a1a..7f947f293494 100644
--- a/net-p2p/rtorrent/distinfo
+++ b/net-p2p/rtorrent/distinfo
@@ -1,3 +1,3 @@
-MD5 (rtorrent-0.6.4.tar.gz) = 9077817e5a0f505e0b71add9c57b89f7
-SHA256 (rtorrent-0.6.4.tar.gz) = bf8ce2a565a69b26490ad34f4d8f429037bba2e5d3949ee88a03f0ebc1d3250b
-SIZE (rtorrent-0.6.4.tar.gz) = 438407
+MD5 (rtorrent-0.7.1.tar.gz) = 98b97730c36828e662a2355cb2b11309
+SHA256 (rtorrent-0.7.1.tar.gz) = 2079c9f4d54b2cfcca5d41be0760ca0d93c6f0f05e3c1f929f66252fbdadcb8b
+SIZE (rtorrent-0.7.1.tar.gz) = 414447
diff --git a/net-p2p/rtorrent/files/stable-src_option__parser.cc b/net-p2p/rtorrent/files/stable-src_option__parser.cc
deleted file mode 100644
index fe21794d59a6..000000000000
--- a/net-p2p/rtorrent/files/stable-src_option__parser.cc
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/option_parser.cc.orig Wed Jul 12 10:31:59 2006
-+++ src/option_parser.cc Wed Jul 12 10:32:15 2006
-@@ -77,9 +77,6 @@
- int c;
- std::string optString = create_optstring();
-
-- optind = 0;
-- opterr = 0;
--
- while ((c = getopt(argc, argv, optString.c_str())) != -1)
- if (c == '?')
- throw std::runtime_error("Invalid/unknown option flag \"-" + std::string(1, (char)optopt) + "\". See rtorrent -h for more information.");