aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-01-15 02:32:32 +0800
committernemysis <nemysis@FreeBSD.org>2014-01-15 02:32:32 +0800
commit774cb2f3ce7070bcb3e83f55c0917c249f3cfc4d (patch)
tree1574f3d6f1b100b7b3243b13dbc4ed446e69fac9 /net-p2p
parent7df70d72c39cf8450620f3ceef5e508f4d28ecbb (diff)
downloadfreebsd-ports-gnome-774cb2f3ce7070bcb3e83f55c0917c249f3cfc4d.tar.gz
freebsd-ports-gnome-774cb2f3ce7070bcb3e83f55c0917c249f3cfc4d.tar.zst
freebsd-ports-gnome-774cb2f3ce7070bcb3e83f55c0917c249f3cfc4d.zip
- Fix build at 11.x [1]
- Use LIB_DEPENDS? instead of LIB_DEPENDS, because Master port have had overwritten the LIB_DEPENDS [1] - Use USES=compiler:c++11-lib instead of compiler:c++11-lang [1] - Use CONFIGURE_ARGS instead of CONFIGURE_ARGS+ [2] - Break lines around 80 characters [2] Reported by: swills [1], danfe [2]
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 0eed76b1e639..10879f067ca0 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -13,15 +13,15 @@ COMMENT?= C++ library implementing a BitTorrent client
LICENSE= BSD
-LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
+LIB_DEPENDS?= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
libGeoIP.so:${PORTSDIR}/net/GeoIP
-USES= compiler:c++11-lang pathfix pkgconfig iconv
+USES= compiler:c++11-lib pathfix pkgconfig iconv
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS+= --disable-debug \
+CONFIGURE_ARGS= --disable-debug \
--disable-static \
--enable-dht \
--enable-encryption \
@@ -69,6 +69,7 @@ post-install:
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} \
+ ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>