aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-21 17:31:25 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-21 17:31:25 +0800
commitc9983b6ed69b31349559fe4008e6b2e88fe191c7 (patch)
treea9846ae0fefe9b6a1c249fec1396d587456b79d5 /net-p2p
parent2f6061169170f45e8b19403451f710d6cfb45b5d (diff)
downloadfreebsd-ports-gnome-c9983b6ed69b31349559fe4008e6b2e88fe191c7.tar.gz
freebsd-ports-gnome-c9983b6ed69b31349559fe4008e6b2e88fe191c7.tar.zst
freebsd-ports-gnome-c9983b6ed69b31349559fe4008e6b2e88fe191c7.zip
Use a more modern way of distinguishing "big-endian platforms".
This will attempt builds on arm platforms on the cluster. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-daemon/Makefile4
-rw-r--r--net-p2p/bitcoin-utils/Makefile6
2 files changed, 5 insertions, 5 deletions
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index 3045aaf97f41..050de2f78d18 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -8,8 +8,8 @@ COMMENT= Virtual Peer-to-Peer Currency (Daemon)
SLAVE_PORT= yes
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= does not support big-endian architectures
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= does not support big-endian architectures
OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
OPTIONS_DEFAULT= HARDENING UPNP WALLET
diff --git a/net-p2p/bitcoin-utils/Makefile b/net-p2p/bitcoin-utils/Makefile
index f63ad4f33914..3830afccd4fe 100644
--- a/net-p2p/bitcoin-utils/Makefile
+++ b/net-p2p/bitcoin-utils/Makefile
@@ -6,12 +6,12 @@ PKGNAMESUFFIX= -utils
COMMENT= Virtual Peer-to-Peer Currency (CLI and Utilities)
SLAVE_PORT= yes
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= does not support big-endian architectures
+
OPTIONS_DEFINE= DEBUG HARDENING TESTS
OPTIONS_DEFAULT= HARDENING TESTS
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= does not support big-endian architectures
-
CONFIGURE_ARGS= --without-daemon \
--without-gui \
--without-libs \