aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2017-11-11 23:36:29 +0800
committervd <vd@FreeBSD.org>2017-11-11 23:36:29 +0800
commitf1a79b6775d1b809a7381ecda8cae54a89c77b06 (patch)
tree0bb70438abbda2e2c309ed9affef81c33226b422 /net-p2p
parent69e5753b5fe21615049d22bb225772e4455e92af (diff)
downloadfreebsd-ports-gnome-f1a79b6775d1b809a7381ecda8cae54a89c77b06.tar.gz
freebsd-ports-gnome-f1a79b6775d1b809a7381ecda8cae54a89c77b06.tar.zst
freebsd-ports-gnome-f1a79b6775d1b809a7381ecda8cae54a89c77b06.zip
net-p2p/monero-cli: Fix compilation on i386
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero-cli/files/patch-CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-p2p/monero-cli/files/patch-CMakeLists.txt b/net-p2p/monero-cli/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..3fed06fbaacc
--- /dev/null
+++ b/net-p2p/monero-cli/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+
+https://github.com/monero-project/monero/pull/2793
+
+--- CMakeLists.txt.orig 2017-11-11 15:31:39 UTC
++++ CMakeLists.txt
+@@ -682,7 +682,7 @@ endif()
+ if(ANDROID)
+ set(ATOMIC libatomic.a)
+ endif()
+-if(CMAKE_C_COMPILER_ID STREQUAL "Clang" AND ARCH_WIDTH EQUAL "32" AND NOT IOS)
++if(CMAKE_C_COMPILER_ID STREQUAL "Clang" AND ARCH_WIDTH EQUAL "32" AND NOT IOS AND NOT FREEBSD)
+ find_library(ATOMIC atomic)
+ list(APPEND EXTRA_LIBRARIES ${ATOMIC})
+ endif()