aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-02-21 09:39:49 +0800
committerlioux <lioux@FreeBSD.org>2002-02-21 09:39:49 +0800
commit7bfd29cc7549f470974d376d2d9c6e9bdcf2d0b4 (patch)
treeb96b0dd6023b5b8eb3bda13e609a150959bdb4f2 /net-p2p
parent3323ea2c491a99d2f22d01c22636b48af9dd09a2 (diff)
downloadfreebsd-ports-gnome-7bfd29cc7549f470974d376d2d9c6e9bdcf2d0b4.tar.gz
freebsd-ports-gnome-7bfd29cc7549f470974d376d2d9c6e9bdcf2d0b4.tar.zst
freebsd-ports-gnome-7bfd29cc7549f470974d376d2d9c6e9bdcf2d0b4.zip
New port edonkey-tool-slist version 0.2: Checks which servers are
either dead or alive in server.met
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/edonkey-tool-slist/Makefile40
-rw-r--r--net-p2p/edonkey-tool-slist/distinfo1
-rw-r--r--net-p2p/edonkey-tool-slist/pkg-comment1
-rw-r--r--net-p2p/edonkey-tool-slist/pkg-descr9
-rw-r--r--net-p2p/edonkey-tool-slist/pkg-plist3
5 files changed, 54 insertions, 0 deletions
diff --git a/net-p2p/edonkey-tool-slist/Makefile b/net-p2p/edonkey-tool-slist/Makefile
new file mode 100644
index 000000000000..1e24678e21c5
--- /dev/null
+++ b/net-p2p/edonkey-tool-slist/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: edonkey server list tool
+# Date created: Wed Feb 20 18:03:49 BRT 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= edonkey
+PORTVERSION= 0.2
+CATEGORIES= misc
+MASTER_SITES= http://users.aber.ac.uk/tpm01/ed2k_tools/
+PKGNAMESUFFIX= -tool-slist
+DISTNAME= ed2k_slist-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/ed2k_slist
+
+post-patch:
+ @${PERL} -pi -e 's|\r\n|\n|' ${WRKSRC}/*.[ch]
+ @${PERL} -pi -e 's|(#include <unistd.h>)|\1\n#include\
+ <sys/time.h>|' ${WRKSRC}/linux_net.c
+
+# I could have written a Makefile but I would rather
+# not waste inodes
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} \
+ ed2k_slist.c -o ${PORTNAME}${PKGNAMESUFFIX}
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+ @${INSTALL_DATA} ${WRKSRC}/COPYING \
+ ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX} \
+ ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net-p2p/edonkey-tool-slist/distinfo b/net-p2p/edonkey-tool-slist/distinfo
new file mode 100644
index 000000000000..132c58b90bc5
--- /dev/null
+++ b/net-p2p/edonkey-tool-slist/distinfo
@@ -0,0 +1 @@
+MD5 (ed2k_slist-0.2.tar.gz) = add551eebc1d8a64e82f77ddbcf91545
diff --git a/net-p2p/edonkey-tool-slist/pkg-comment b/net-p2p/edonkey-tool-slist/pkg-comment
new file mode 100644
index 000000000000..59a83aaa6410
--- /dev/null
+++ b/net-p2p/edonkey-tool-slist/pkg-comment
@@ -0,0 +1 @@
+Checks which servers are either dead or alive in server.met
diff --git a/net-p2p/edonkey-tool-slist/pkg-descr b/net-p2p/edonkey-tool-slist/pkg-descr
new file mode 100644
index 000000000000..cd22b70a6311
--- /dev/null
+++ b/net-p2p/edonkey-tool-slist/pkg-descr
@@ -0,0 +1,9 @@
+This tool takes your server.met file and checks which servers are
+dead and which are alive. It then creates a new server.met file
+which contains only working servers. It makes sense to use this
+tool every time before you start the eDonkey 2000 client.
+
+On request this tool also creates a web page with ed2k:// links to
+all working servers.
+
+WWW: http://users.aber.ac.uk/tpm01/ed2k_tools/
diff --git a/net-p2p/edonkey-tool-slist/pkg-plist b/net-p2p/edonkey-tool-slist/pkg-plist
new file mode 100644
index 000000000000..bada7d073657
--- /dev/null
+++ b/net-p2p/edonkey-tool-slist/pkg-plist
@@ -0,0 +1,3 @@
+bin/edonkey-tool-slist
+%%PORTDOCS%%share/doc/edonkey-tool-slist/COPYING
+%%PORTDOCS%%@dirrm share/doc/edonkey-tool-slist