aboutsummaryrefslogtreecommitdiffstats
path: root/net/3proxy/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-07-30 15:36:28 +0800
committerkrion <krion@FreeBSD.org>2003-07-30 15:36:28 +0800
commitbb521ae8abe8b21e8cb5c718ced2116b8751a05e (patch)
tree8174793f209d1e567feed066e8156702cdf2c10c /net/3proxy/Makefile
parentb0f34bace94921fc88b8055785a654f7831063bb (diff)
downloadfreebsd-ports-gnome-bb521ae8abe8b21e8cb5c718ced2116b8751a05e.tar.gz
freebsd-ports-gnome-bb521ae8abe8b21e8cb5c718ced2116b8751a05e.tar.zst
freebsd-ports-gnome-bb521ae8abe8b21e8cb5c718ced2116b8751a05e.zip
New port: net/3proxy
3[APA3A] tiny proxy 3Proxy (pronounce it as "Zaraza tiny proxy") is really tiny cross-platform (Win32&Unix) proxy servers set. It includes HTTP proxy with HTTPS and FTP support, SOCKSv4/SOCKSv4.5/SOCKSv5 proxy, POP3 proxy, TCP and UDP portmappers. You can use every proxy as a standalone program (socks, proxy, tcppm, udppm, pop3p) or use combined program (3proxy). PR: 54968 Submitted by: Timofey Chernousov <tim@gwd.nnn.tstu.ru> Approved by: fjoe (mentor) (implicit)
Diffstat (limited to 'net/3proxy/Makefile')
-rw-r--r--net/3proxy/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
new file mode 100644
index 000000000000..98512e6832af
--- /dev/null
+++ b/net/3proxy/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: 3proxy
+# Date created: 2003 July 25
+# Whom: tim@relay.nnn.tstu.ru
+#
+# $FreeBSD$
+#
+
+PORTNAME= 3proxy
+PORTVERSION= 0.4b
+CATEGORIES= net
+MASTER_SITES= http://www.security.nnov.ru/soft/3proxy/${PORTVERSION}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= tim@relay.nnn.tstu.ru
+COMMENT= Proxy servers set (support HTTP(S), FTP, SOCKS, POP3, TCP & UDP)
+
+NO_WRKSUBDIR= yes
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+
+pre-build:
+ if [ ! -f ${WRKSRC}/Makefile ]; then \
+ ${CP} ${WRKSRC}/Makefile.unix ${WRKSRC}/Makefile; \
+ fi
+
+do-install:
+.for i in 3proxy dighosts mycrypt pop3p proxy socks tcppm udppm
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin/
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/3proxy.cfg.sample ${PREFIX}/etc
+ ${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/3proxy.sh \
+ > ${WRKSRC}/3proxy.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/3proxy.sh ${PREFIX}/etc/rc.d/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in License Readme Release.notes
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>