aboutsummaryrefslogtreecommitdiffstats
path: root/net/4g8/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-25 18:57:00 +0800
committerkrion <krion@FreeBSD.org>2004-01-25 18:57:00 +0800
commit25c756027f15aec4ae318740a12283e47260fd39 (patch)
tree3705cb868ba4cd7f9e004306dae5b32686f783a8 /net/4g8/Makefile
parent53593d32ca3d6fbabb961d9da1892748eab6a20e (diff)
downloadfreebsd-ports-gnome-25c756027f15aec4ae318740a12283e47260fd39.tar.gz
freebsd-ports-gnome-25c756027f15aec4ae318740a12283e47260fd39.tar.zst
freebsd-ports-gnome-25c756027f15aec4ae318740a12283e47260fd39.zip
Forgate (Forge Gateway) is a tool that allows you to capture
traffic from a third party in a switched environment at the expense of a slight increase in latency to that third party host. Utilizing ARP cache poisoning, packet capture, and packet reconstruction techniques, it works with nearly all TCP, ICMP, and UDP IPv4 traffic flows.
Diffstat (limited to 'net/4g8/Makefile')
-rw-r--r--net/4g8/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/4g8/Makefile b/net/4g8/Makefile
new file mode 100644
index 000000000000..9bf0edc3ce9d
--- /dev/null
+++ b/net/4g8/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: forgate
+# Date created: 25.01.2004
+# Whom: krion
+#
+# $FreeBSD$
+#
+
+PORTNAME= forgate
+PORTVERSION= 0.9
+CATEGORIES= net
+MASTER_SITES= http://forgate.sourceforge.net/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Forgate is a tool that allows you to capture traffic
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= sbin/forgate
+
+.include <bsd.port.mk>