aboutsummaryrefslogtreecommitdiffstats
path: root/net/6tunnel
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-09-02 22:30:12 +0800
committersem <sem@FreeBSD.org>2005-09-02 22:30:12 +0800
commitb8738da0721064d8d04338abf7859e2469c307e0 (patch)
tree50526b89255356b1ffa6e4bb5992ee7d11b75285 /net/6tunnel
parent6c0b42575789d435625b3bf3ee06d8996d1950e9 (diff)
downloadfreebsd-ports-gnome-b8738da0721064d8d04338abf7859e2469c307e0.tar.gz
freebsd-ports-gnome-b8738da0721064d8d04338abf7859e2469c307e0.tar.zst
freebsd-ports-gnome-b8738da0721064d8d04338abf7859e2469c307e0.zip
- Update to 0.11.r2
PR: ports/85633 Submitted by: Andrej Zverev <az@inec.ru>
Diffstat (limited to 'net/6tunnel')
-rw-r--r--net/6tunnel/Makefile16
-rw-r--r--net/6tunnel/distinfo4
-rw-r--r--net/6tunnel/files/patch-configure11
-rw-r--r--net/6tunnel/files/patch-configure.in13
4 files changed, 27 insertions, 17 deletions
diff --git a/net/6tunnel/Makefile b/net/6tunnel/Makefile
index 88138535f436..c85777b56a6f 100644
--- a/net/6tunnel/Makefile
+++ b/net/6tunnel/Makefile
@@ -6,20 +6,28 @@
#
PORTNAME= 6tunnel
-PORTVERSION= 0.11.r1
+PORTVERSION= 0.11.r2
CATEGORIES= net ipv6
MASTER_SITES= http://toxygen.net/6tunnel/
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}rc1
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}rc2
MAINTAINER= ports@FreeBSD.org
COMMENT= TCP proxy for applications that don't speak IPv6
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}rc2
+
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_AUTOCONF_VER= 259
ALL_TARGET= default
MAN1= 6tunnel.1
MANCOMPRESSED= no
PLIST_FILES= bin/6tunnel
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ @cd ${WRKSRC}; ${AUTOCONF}
+
+.include <bsd.port.post.mk>
diff --git a/net/6tunnel/distinfo b/net/6tunnel/distinfo
index 1253578a535d..7b1b09de5306 100644
--- a/net/6tunnel/distinfo
+++ b/net/6tunnel/distinfo
@@ -1,2 +1,2 @@
-MD5 (6tunnel-0.11rc1.tar.gz) = b325fa9d238e32195fbb3fc3646b0d28
-SIZE (6tunnel-0.11rc1.tar.gz) = 38126
+MD5 (6tunnel-0.11rc2.tar.gz) = 74e02d4f0704b3083a01feda66033449
+SIZE (6tunnel-0.11rc2.tar.gz) = 17522
diff --git a/net/6tunnel/files/patch-configure b/net/6tunnel/files/patch-configure
deleted file mode 100644
index a6f2e79caedd..000000000000
--- a/net/6tunnel/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Wed Feb 16 13:47:48 2005
-+++ configure Wed Feb 16 13:48:05 2005
-@@ -3188,6 +3188,8 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
-+#include <sys/types.h>
-+#include <sys/socket.h>
- #include <netinet/in.h>
- int
- main ()
diff --git a/net/6tunnel/files/patch-configure.in b/net/6tunnel/files/patch-configure.in
new file mode 100644
index 000000000000..e7d373221c5a
--- /dev/null
+++ b/net/6tunnel/files/patch-configure.in
@@ -0,0 +1,13 @@
+--- configure.in.orig Sun Nov 24 03:59:24 2002
++++ configure.in Fri Sep 2 16:04:11 2005
+@@ -18,7 +18,9 @@
+ AC_CHECK_FUNCS(getaddrinfo, , AC_MSG_ERROR([Your system doesn't support IPv6.]))
+
+ AC_MSG_CHECKING([for AF_INET6])
+-AC_TRY_COMPILE([#include <netinet/in.h>], [int x = AF_INET6;], [
++AC_TRY_COMPILE([#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>], [int x = AF_INET6;], [
+ AC_MSG_RESULT(yes)
+ ], [
+ AC_MSG_RESULT(no)