aboutsummaryrefslogtreecommitdiffstats
path: root/net/SSLtelnet/files
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-04-11 23:07:05 +0800
committervanilla <vanilla@FreeBSD.org>1998-04-11 23:07:05 +0800
commit5d750f66088d1e6fdfc57659ba3cc23a026aa63b (patch)
tree7c2e328f542b545b119468a91e44409c4fd558ab /net/SSLtelnet/files
parent33926b281f3af4009c0c027812045934e4ca501d (diff)
downloadfreebsd-ports-gnome-5d750f66088d1e6fdfc57659ba3cc23a026aa63b.tar.gz
freebsd-ports-gnome-5d750f66088d1e6fdfc57659ba3cc23a026aa63b.tar.zst
freebsd-ports-gnome-5d750f66088d1e6fdfc57659ba3cc23a026aa63b.zip
It is a telnet/telnetd program support SSL encryption
and certification mechanism. PR: ports/6182 Submitted by: Issei Suzuki <issei@t-cnet.or.jp
Diffstat (limited to 'net/SSLtelnet/files')
-rw-r--r--net/SSLtelnet/files/patch-aa57
-rw-r--r--net/SSLtelnet/files/patch-ab9
-rw-r--r--net/SSLtelnet/files/patch-ac11
-rw-r--r--net/SSLtelnet/files/patch-ad11
4 files changed, 88 insertions, 0 deletions
diff --git a/net/SSLtelnet/files/patch-aa b/net/SSLtelnet/files/patch-aa
new file mode 100644
index 000000000000..fa240b6c7953
--- /dev/null
+++ b/net/SSLtelnet/files/patch-aa
@@ -0,0 +1,57 @@
+--- ../../SSLtelnet-0.11/Makefile Sat Aug 2 16:08:25 1997
++++ ./Makefile Sun Mar 29 18:28:44 1998
+@@ -47,7 +47,7 @@
+
+ # the location where SSLeay is installed ...
+ # - expect a include and lib directory under here
+-SSLTOP=/usr/local/ssl
++SSLTOP=$(PREFIX)
+
+ INSTALLTOP=$(SSLTOP)
+
+@@ -83,8 +83,8 @@
+ #LDADD=$(sockslib) -ltermcap -lcurses
+
+ # uncomment the next two lines for linux
+-CC = gcc -DLINUX -DTERMIOS $(socksflags)
+-LDADD = $(sockslib) -lbsd -lncurses
++#CC = gcc -DLINUX -DTERMIOS $(socksflags)
++#LDADD = $(sockslib) -lbsd -lncurses
+
+ ##OLD Linux stuff
+ #CC = gcc -DLINUX -DUSE_SHADOW $(socksflags)
+@@ -95,6 +95,10 @@
+ #BSD386
+ #CC = gcc -DBSD386 -DTERMCAP $(socksflags)
+ #LDADD = -ltermcap $(sockslib)
++
++#BSD386
++CC = gcc -DTERMCAP $(socksflags)
++LDADD = -ltermcap $(sockslib)
+
+ all:
+ @-mkdir bin 2>/dev/null
+@@ -145,12 +149,11 @@
+ tar: clean
+ (cd ..; tar cf $(TARFILE) $(DIRECTORY); /bin/rm -f $(TARFILE).Z $(TARFILE).gz >/dev/null 2>&1 ; $(COMPRESS) $(TARFILE) )
+
+-install: telnet telnetd /dev/null
+- @-mkdir -p $(INSTALLTOP)/bin 2>/dev/null
++install: telnet telnetd
+ cp bin/telnet $(INSTALLTOP)/bin/telnet
+ chmod 755 $(INSTALLTOP)/bin/telnet
+- cp bin/telnetd $(INSTALLTOP)/bin/telnetd
+- chmod 755 $(INSTALLTOP)/bin/telnetd
++ cp bin/telnetd $(INSTALLTOP)/libexec/telnetd
++ chmod 755 $(INSTALLTOP)/libexec/telnetd
+ @echo "*****************************************************"
+ @echo "* Do not forget to make the certificate for telnetd *"
+ @echo "* either manually or via \"make certificate\" *"
+@@ -158,6 +161,7 @@
+
+ certificate:
+ (\
++ [ -f $(INSTALLTOP)/certs/telnetd.pem ] && exit; \
+ cd $(INSTALLTOP)/certs; \
+ ssleay req -new -x509 -nodes -days 365 -out telnetd.pem -keyout telnetd.pem; \
+ ln -s telnetd.pem `ssleay x509 -noout -hash < telnetd.pem`.0 ;\
diff --git a/net/SSLtelnet/files/patch-ab b/net/SSLtelnet/files/patch-ab
new file mode 100644
index 000000000000..1c33746c2dd9
--- /dev/null
+++ b/net/SSLtelnet/files/patch-ab
@@ -0,0 +1,9 @@
+--- ../../SSLtelnet-0.11/lib/libbsd/Makefile Fri Jun 30 09:05:37 1995
++++ ./lib/libbsd/Makefile Sun Mar 29 14:31:30 1998
+@@ -1,5 +1,5 @@
+ LIB= bsd
+-CFLAGS= -DLIBC_SCCS -I../../include
++CFLAGS+= -DLIBC_SCCS -I$(PREFIX)/include
+ OBJS= getenv.o herror.o setenv.o strerror.o getpass.o inet_addr.o
+
+ lib${LIB}.a: ${OBJS}
diff --git a/net/SSLtelnet/files/patch-ac b/net/SSLtelnet/files/patch-ac
new file mode 100644
index 000000000000..6267b8de590b
--- /dev/null
+++ b/net/SSLtelnet/files/patch-ac
@@ -0,0 +1,11 @@
+--- ../../SSLtelnet-0.11/lib/libbsd/getpass.c Sat Jun 15 18:28:30 1996
++++ ./lib/libbsd/getpass.c Sun Mar 29 14:30:01 1998
+@@ -6,7 +6,7 @@
+
+ #define TTY "/dev/tty"
+
+-#if !defined(HPUX) && !defined(__bsdi__)
++#if !defined(HPUX) && !defined(__bsdi__) && !defined(__FreeBSD__)
+
+ /* under HPUX use the "system" supplied routine as I cannot
+ * be bothered to "port" this code at the moment --tjh
diff --git a/net/SSLtelnet/files/patch-ad b/net/SSLtelnet/files/patch-ad
new file mode 100644
index 000000000000..90103280daa8
--- /dev/null
+++ b/net/SSLtelnet/files/patch-ad
@@ -0,0 +1,11 @@
+--- ../../SSLtelnet-0.11/lib/libbsd/inet_addr.c Sat Jun 15 18:28:34 1996
++++ ./lib/libbsd/inet_addr.c Sun Mar 29 14:33:07 1998
+@@ -37,7 +37,7 @@
+
+ #if defined(__GNUC__)
+
+-#if defined(__bsdi__) || defined(SUNOS) && !defined(SOLARIS2)
++#if defined(__bsdi__) || defined(SUNOS) && !defined(SOLARIS2) || defined(__FreeBSD__)
+
+ /* nothing required for SunOS 4.1.x */
+