aboutsummaryrefslogtreecommitdiffstats
path: root/net/arla/files
diff options
context:
space:
mode:
authorassar <assar@FreeBSD.org>2001-09-09 01:08:42 +0800
committerassar <assar@FreeBSD.org>2001-09-09 01:08:42 +0800
commitdbcc8c9b179ab265e6725d2a81dd3a455b1c7a98 (patch)
tree0c592537f64fc298c074ead6fcf9355b12571395 /net/arla/files
parent921fe226b1af509200ee99da26c4d15ef89a627b (diff)
downloadfreebsd-ports-gnome-dbcc8c9b179ab265e6725d2a81dd3a455b1c7a98.tar.gz
freebsd-ports-gnome-dbcc8c9b179ab265e6725d2a81dd3a455b1c7a98.tar.zst
freebsd-ports-gnome-dbcc8c9b179ab265e6725d2a81dd3a455b1c7a98.zip
do not install libutil, since it conflicts with /usr/lib/libutil*
PR: ports/30417 Submitted by: Emil Sit <sit@mit.edu> Obtained from: NetBSD pkgsrc by way of Emil Sit <sit@mit.edu>
Diffstat (limited to 'net/arla/files')
-rw-r--r--net/arla/files/patch-aa34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/arla/files/patch-aa b/net/arla/files/patch-aa
new file mode 100644
index 000000000000..d9ddd96833de
--- /dev/null
+++ b/net/arla/files/patch-aa
@@ -0,0 +1,34 @@
+--- util/Makefile.in.orig Sat Sep 8 18:55:41 2001
++++ util/Makefile.in Sat Sep 8 18:56:07 2001
+@@ -78,31 +78,8 @@
+ libutil_LIB: $(libutil_OBJS)
+
+ install: all
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
+- $(INSTALL_DATA) $(LIB) $(DESTDIR)$(libdir)/$(LIB)
+- for i in $(HEADERS); do \
+- $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir)/$$i; \
+- done ; \
+- MANPAGES='$(MANPAGES)'; for x in $$MANPAGES; do \
+- n=`echo $$x | sed 's/\(.*\)\.[1-9a-zA-Z]*$$/\1/'`; \
+- e=`echo $$x | sed 's/.*\.\([1-9a-zA-Z]*\)$$/\1/'`; \
+- f=`echo $$n | sed '$(transform)'`; \
+- $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man$$e ; \
+- $(INSTALL_DATA) $(srcdir)/$$x \
+- $(DESTDIR)$(mandir)/man$$e/$$f.$$e; \
+- done
+
+ uninstall:
+- rm -f $(DESTDIR)$(libdir)/$(LIB)
+- for i in $(HEADERS); do \
+- rm -f $(DESTDIR)$(includedir)/$$i; \
+- done ; \
+- MANPAGES='$(MANPAGES)'; for x in $$MANPAGES; do \
+- n=`echo $$x | sed 's/\(.*\)\.[1-9a-zA-Z]*$$/\1/'`; \
+- e=`echo $$x | sed 's/.*\.\([1-9a-zA-Z]*\)$$/\1/'`; \
+- f=`echo $$n | sed '$(transform)'`; \
+- rm -rf $(DESTDIR)$(mandir)/$$f.$$e; \
+- done
+
+ libutil.a: $(libutil_OBJS)
+ $(AR) cr $@ $(libutil_OBJS)