aboutsummaryrefslogtreecommitdiffstats
path: root/net/arping
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /net/arping
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'net/arping')
-rw-r--r--net/arping/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index a59180eb230f..8d96f3b7933b 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -17,10 +17,10 @@ COMMENT= ARP level "ping" utility
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS+="`${LIBNET_CONFIG} --defines`" \
- CPPFLAGS="-I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="`${LIBNET_CONFIG} --libs` -lpcap"
+CONFIGURE_ENV= LIBS="`${LIBNET_CONFIG} --libs` -lpcap"
+CFLAGS+= `${LIBNET_CONFIG} --defines`
+CPPFLAGS+= -I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`
+LDFLAGS+= -L${LOCALBASE}/lib
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config