aboutsummaryrefslogtreecommitdiffstats
path: root/net/arping
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-15 10:43:14 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-15 10:43:14 +0800
commita1bcbdd5e22ff554422254c867f7870add9b5ba8 (patch)
tree4faae43f9635a121d72a57938e57a630c82ff029 /net/arping
parentea62c0dc460f12156b965ca30033181596ece7ae (diff)
downloadfreebsd-ports-gnome-a1bcbdd5e22ff554422254c867f7870add9b5ba8.tar.gz
freebsd-ports-gnome-a1bcbdd5e22ff554422254c867f7870add9b5ba8.tar.zst
freebsd-ports-gnome-a1bcbdd5e22ff554422254c867f7870add9b5ba8.zip
- if net/libpcap from ports is install, net/arping bombs b/c of errors in pcap.h
fix this. Versions of this patch are committed upstream. - Bump PORTREVISION PR: ports/151263 Submitted by: Lucius Windschuh <lwindschuh@gmail.com> Approved by: maintainer timeout (gavin ; 67 days)
Diffstat (limited to 'net/arping')
-rw-r--r--net/arping/Makefile1
-rw-r--r--net/arping/files/patch-src__arping.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index 5691a8eadf0a..a59180eb230f 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -7,6 +7,7 @@
PORTNAME= arping
PORTVERSION= 2.09
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.habets.pp.se/synscan/files/
diff --git a/net/arping/files/patch-src__arping.c b/net/arping/files/patch-src__arping.c
new file mode 100644
index 000000000000..6abada91f23d
--- /dev/null
+++ b/net/arping/files/patch-src__arping.c
@@ -0,0 +1,22 @@
+--- ./src/arping.c.orig 2010-12-15 02:40:26.572881702 +0000
++++ ./src/arping.c 2010-12-15 02:41:01.891883112 +0000
+@@ -75,15 +75,15 @@
+ #include <libnet.h>
+ #endif
+
++#if HAVE_NET_BPF_H
++#include <net/bpf.h>
++#endif
++
+ #if HAVE_WIN32_LIBNET_H
+ #include <win32/libnet.h>
+ #endif
+ #include <pcap.h>
+
+-#if HAVE_NET_BPF_H
+-#include <net/bpf.h>
+-#endif
+-
+ #ifndef ETH_ALEN
+ #define ETH_ALEN 6
+ #endif