aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-04-16 16:40:15 +0800
committersobomax <sobomax@FreeBSD.org>2007-04-16 16:40:15 +0800
commite5635fb59284725531b07a59568a40f721a83d5d (patch)
treee969de496d9b1ad011879bef431300e458fa8db3 /net/asterisk/Makefile
parentd60a27ee2832f3d7628b192c36952e994544965f (diff)
downloadfreebsd-ports-gnome-e5635fb59284725531b07a59568a40f721a83d5d.tar.gz
freebsd-ports-gnome-e5635fb59284725531b07a59568a40f721a83d5d.tar.zst
freebsd-ports-gnome-e5635fb59284725531b07a59568a40f721a83d5d.zip
Add Jabber and Gtalk support.
PR: 111553 Submitted by: pneumann at gmail.com
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 664a9fb2fef4..5c0fd913bed2 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -43,7 +43,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on
+ H323 "Enable H.323 support" on \
+ JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -123,6 +124,15 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
.endif
+.if defined(WITHOUT_JABBER)
+PLIST_SUB+= WITH_JABBER="@comment "
+CONFIGURE_ARGS+= --without-iksemel
+.else
+PLIST_SUB+= WITH_JABBER=""
+CONFIGURE_ARGS+= --with-iksemel
+LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample