aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-05-11 05:19:34 +0800
committerflo <flo@FreeBSD.org>2011-05-11 05:19:34 +0800
commit3ad59aef0ac81b798ca38d70fe34aa1af6a6d626 (patch)
tree20939f26da3eac3874eddb7cd617343541060d80 /net/asterisk/Makefile
parentee0aa216a4b9ba7103221d2c6ea2de79c92b46d1 (diff)
downloadfreebsd-ports-gnome-3ad59aef0ac81b798ca38d70fe34aa1af6a6d626.tar.gz
freebsd-ports-gnome-3ad59aef0ac81b798ca38d70fe34aa1af6a6d626.tar.zst
freebsd-ports-gnome-3ad59aef0ac81b798ca38d70fe34aa1af6a6d626.zip
- update to 1.8.4
- add lua support [1] - add libsrtp support [2] PR: ports/156775 [2] Submitted by: Andre Luiz dos Santo [1] Alexander Brovikov [2]
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 2f55bf32fcb5..4bd13166fcd9 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.3.3
+PORTVERSION= 1.8.4
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -60,7 +60,9 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
ILBC "Enable iLBC codec" off \
SPANDSP "Enable Spandsp faxing support" off \
EXCHANGE "Enable Exchange calendar support" off \
- NEWG711 "Enable new G711 Codec" off
+ NEWG711 "Enable new G711 Codec" off \
+ SRTP "Enable SecureRTP support" off \
+ LUA "Enable LUA extensions support" off
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -257,6 +259,26 @@ PLIST_SUB+= WITH_EXCHANGE=""
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-menuselect-tree-g711-new-codec.diff
.endif
+.if !defined(WITH_SRTP)
+PLIST_SUB+= WITH_SRTP="@comment "
+CONFIGURE_ARGS+= --without-srtp
+.else
+PLIST_SUB+= WITH_SRTP=""
+BUILD_DEPENDS+= libsrtp>=1.4.4:${PORTSDIR}/net/libsrtp
+CONFIGURE_ARGS+= --with-srtp
+.endif
+
+.if defined(WITH_LUA)
+CONFIGURE_ARGS+= --with-lua
+CFLAGS+= -I${LUA_INCDIR}
+USE_LUA= yes
+LDFLAGS+= -L${LUA_LIBDIR}
+PLIST_SUB+= WITH_LUA=""
+.else
+CONFIGURE_ARGS+= --without-lua
+PLIST_SUB+= WITH_LUA="@comment "
+.endif
+
.if defined(WITH_MISC_PATCHES)
EXTRA_PATCHES+= ${PATCHDIR}/dtmf_debug.diff
EXTRA_PATCHES+= ${PATCHDIR}/feature_disconnect.diff