aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2005-05-03 21:39:48 +0800
committersobomax <sobomax@FreeBSD.org>2005-05-03 21:39:48 +0800
commit876d324c59378bf7801889410673eb99d7b5408b (patch)
tree45bef2f358c4784b9838d2d05319a4edb27c008f /net/asterisk/Makefile
parent0db4065435e78d4345bfa44c1df96864e2b453d4 (diff)
downloadfreebsd-ports-gnome-876d324c59378bf7801889410673eb99d7b5408b.tar.gz
freebsd-ports-gnome-876d324c59378bf7801889410673eb99d7b5408b.tar.zst
freebsd-ports-gnome-876d324c59378bf7801889410673eb99d7b5408b.zip
pbx_wilcalu.c:
new patch for this file, smooths the effects of an unhandled error Cexiting from poll() and resulting otherwise in this process taking 100% of the CPU rtp.c: updated patch for rtp.c, removes a misleading 'checksum error' message when in reality the recvfrom() just returned no data; chan_oss.c: replacement for the old chan_oss.c - the changes are so massive that having a patch would be completely unreadable. Among other things this lets you change many /dev/dsp parameters from the config file, to ease adapting to the idiosincracies of various sound cards and drivers. It also supports multiple soundcards on the same box, which might be useful in some cases. Submitted by: luigi Add WITHOUT_MYSQL knob. Suggested by: phantom
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index bf9289fc189c..00cb6ce94061 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -20,12 +20,10 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
-BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
- mpg123:${PORTSDIR}/audio/mpg123
+BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
LIB_DEPENDS= speex.3:${PORTSDIR}/audio/speex \
newt.51:${PORTSDIR}/devel/newt
-RUN_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
- mpg123:${PORTSDIR}/audio/mpg123
+RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
ONLY_FOR_ARCHS= i386 sparc64
@@ -71,4 +69,12 @@ RUN_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
PLIST_SUB+= WITH_ZAPTEL=""
.endif
+.if !defined(WITHOUT_MYSQL)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+RUN_DEPENDS+= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+.endif
+
+post-patch:
+ ${CP} ${FILESDIR}/chan_oss.c ${WRKSRC}/channels
+
.include <bsd.port.post.mk>