aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2004-12-29 08:01:54 +0800
committersobomax <sobomax@FreeBSD.org>2004-12-29 08:01:54 +0800
commit8ccd39fdbf8f3d136ffd7295f390e5a915d909a5 (patch)
tree3ebefc2fb8b43ef01a2125141b3fcd9d4d2ba74e /net/asterisk/Makefile
parent255ebf4e7626ddf13df60a44f13a987b364ade65 (diff)
downloadfreebsd-ports-gnome-8ccd39fdbf8f3d136ffd7295f390e5a915d909a5.tar.gz
freebsd-ports-gnome-8ccd39fdbf8f3d136ffd7295f390e5a915d909a5.tar.zst
freebsd-ports-gnome-8ccd39fdbf8f3d136ffd7295f390e5a915d909a5.zip
o Provide rc.d script;
o Fix build on 5.2.1. Submitted by: Marat N.Afanasyev <amarat@ksu.ru>
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index f82e980a1a74..97b6dcea0d10 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -24,6 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
+USE_RC_SUBR= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -59,4 +61,7 @@ RUN_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
PLIST_SUB+= WITH_ZAPTEL=""
.endif
+post-install:
+ @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+
.include <bsd.port.post.mk>