aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-10-17 19:22:52 +0800
committersobomax <sobomax@FreeBSD.org>2003-10-17 19:22:52 +0800
commit833e5e373d9b0cf324df571c69ad7fe349abc376 (patch)
treedbc33242b36bcccbd6fc83b4cb58335a83063330 /net/asterisk/Makefile
parente2a21e1e7649b3fd2cee9922499262b285089df8 (diff)
downloadfreebsd-ports-gnome-833e5e373d9b0cf324df571c69ad7fe349abc376.tar.gz
freebsd-ports-gnome-833e5e373d9b0cf324df571c69ad7fe349abc376.tar.zst
freebsd-ports-gnome-833e5e373d9b0cf324df571c69ad7fe349abc376.zip
Add asterisk 0.5.0, an Open Source PBX and telephony toolkit.
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
new file mode 100644
index 000000000000..870aaae229af
--- /dev/null
+++ b/net/asterisk/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: asterisk
+# Date created: 17 October 2003
+# Whom: Maxim Sobolev <sobomax@portaone.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk
+PORTVERSION= 0.5.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+
+MAINTAINER= sobomax@FreeBSD.org
+COMMENT= An Open Source PBX and telephony toolkit
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+RUN_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+
+GNU_CONFIGURE= yes
+CONFIGURE_WRKSRC= ${WRKSRC}/editline
+USE_GMAKE= yes
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ MKDIR="${MKDIR}"
+
+.include <bsd.port.mk>