aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk10
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-09-13 17:39:53 +0800
committerflo <flo@FreeBSD.org>2012-09-13 17:39:53 +0800
commita26416d4d6ebc46886650212695eecd37e127a1a (patch)
tree0ece8926d7197a2caa2940b8afb4556041c3bb0c /net/asterisk10
parent824d2c6da5170e761fc993643ceeaa20d831b1be (diff)
downloadfreebsd-ports-gnome-a26416d4d6ebc46886650212695eecd37e127a1a.tar.gz
freebsd-ports-gnome-a26416d4d6ebc46886650212695eecd37e127a1a.tar.zst
freebsd-ports-gnome-a26416d4d6ebc46886650212695eecd37e127a1a.zip
- fix typo --with-mysql does not exist, use --with-mysqlclient
- use OPTIONS_DEFINE_$ARCH for DAHDI option, which fixes the option - bump PORTREVISION so the packages have DAHDI support again PR: ports/171590 Submitted by: Dmitry <dmitry2004@yandex.ru>
Diffstat (limited to 'net/asterisk10')
-rw-r--r--net/asterisk10/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 9a7ca4a1477c..1b2e57755b8f 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 10.7.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -52,10 +53,19 @@ OPTIONS_DEFAULT= VORBIS ODBC UNIXODBC PGSQL RADIUS SNMP H323 FREETDS JABBER GSM
OPTIONS_SINGLE= ODBC
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
+OPTIONS_DEFINE_i386= DAHDI
+OPTIONS_DEFINE_amd64= DAHDI
+OPTIONS_DEFINE_sparc64= DAHDI
+
+OPTIONS_DEFAULT_i386= DAHDI
+OPTIONS_DEFAULT_amd64= DAHDI
+OPTIONS_DEFAULT_sparc64= DAHDI
+
EXCHANGE_DESC?= Exchange calendar support
NEWG711_DESC?= New G711 Codec
SRTP_DESC?= SecureRTP support
OOH323_DESC?= ooh323 support
+DAHDI_DESC?= DAHDI support
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -71,12 +81,6 @@ VARDIR=/var
VARDIR=${PREFIX}/var
.endif
-.if ${ARCH} == "i386" || ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-OPTIONS_DEFINE+= DAHDI
-OPTIONS_DEFAULT+= DAHDI
-DAHDI_DESC?= DAHDI support
-.endif
-
SUB_LIST+= ASTERISK_USER=${ASTERISK_USER}
PLIST_SUB+= ASTERISK_USER=${ASTERISK_USER}
PLIST_SUB+= ASTERISK_GROUP=${ASTERISK_GROUP}
@@ -149,10 +153,10 @@ CONFIGURE_ARGS+= --without-postgres
.if ${PORT_OPTIONS:MMYSQL}
PLIST_SUB+= WITH_MYSQL=""
USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql
+CONFIGURE_ARGS+= --with-mysqlclient
.else
PLIST_SUB+= WITH_MYSQL="@comment "
-CONFIGURE_ARGS+= --without-mysql
+CONFIGURE_ARGS+= --without-mysqlclient
.endif
.if ${PORT_OPTIONS:MVORBIS}