aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk14/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2004-04-30 13:21:08 +0800
committersobomax <sobomax@FreeBSD.org>2004-04-30 13:21:08 +0800
commitb99d93794043cdde524e502cc7905c42b3d9e995 (patch)
tree434d4b17b45eebabaec6fd179da8d074a690205e /net/asterisk14/Makefile
parent3bc3546551c8171b536c494f804452391e420c24 (diff)
downloadfreebsd-ports-gnome-b99d93794043cdde524e502cc7905c42b3d9e995.tar.gz
freebsd-ports-gnome-b99d93794043cdde524e502cc7905c42b3d9e995.tar.zst
freebsd-ports-gnome-b99d93794043cdde524e502cc7905c42b3d9e995.zip
- Update to 0.9.0;
- add optional support for building with Zaptel module.
Diffstat (limited to 'net/asterisk14/Makefile')
-rw-r--r--net/asterisk14/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 82db2899e80a..363d7a4f78b9 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 0.7.2
+PORTVERSION= 0.9.0
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -14,8 +14,6 @@ MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
ONLY_FOR_ARCHS= i386
BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
@@ -36,4 +34,14 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
OSVERSION=${OSVERSION} \
CXX="${CXX}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ZAPTEL) || exists(${LOCALBASE}/include/zaptel.h)
+BUILD_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
+RUN_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
+PLIST_SUB= ZAPTEL=""
+.else
+PLIST_SUB= ZAPTEL="@comment "
+.endif
+
+.include <bsd.port.post.mk>