aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk14/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-05-29 04:21:08 +0800
committersobomax <sobomax@FreeBSD.org>2007-05-29 04:21:08 +0800
commitdcf163850153199bfedd810d80b5a17f1091f91d (patch)
treebfabd448aedfdd4e2b2bf84f08b3cfdc72166dd7 /net/asterisk14/Makefile
parent9c554beed06b1fb9ac87cadfba4168ce1f5b2866 (diff)
downloadfreebsd-ports-gnome-dcf163850153199bfedd810d80b5a17f1091f91d.tar.gz
freebsd-ports-gnome-dcf163850153199bfedd810d80b5a17f1091f91d.tar.zst
freebsd-ports-gnome-dcf163850153199bfedd810d80b5a17f1091f91d.zip
Add FreeTDS support. Bump PORTREVISION.
Submitted by: Alex Miller <asm@asm.kiev.ua>
Diffstat (limited to 'net/asterisk14/Makefile')
-rw-r--r--net/asterisk14/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index c036d53fda6a..c9024c4cd57d 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.4.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -44,6 +45,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
H323 "Enable H.323 support" on \
+ FREETDS "Enable FreeTDS support" on \
JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -88,6 +90,15 @@ CONFIGURE_ARGS+= --with-odbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.endif
+.if defined(WITHOUT_FREETDS)
+PLIST_SUB+= WITH_FREETDS="@comment "
+CONFIGURE_ARGS+= --without-tds
+.else
+PLIST_SUB+= WITH_FREETDS=""
+CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
+LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
+.endif
+
.if defined(WITHOUT_POSTGRES)
PLIST_SUB+= WITH_POSTGRES="@comment "
CONFIGURE_ARGS+= --without-postgres