aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk16/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2008-06-10 16:30:35 +0800
committersobomax <sobomax@FreeBSD.org>2008-06-10 16:30:35 +0800
commit7defe680bea8d316c0358e1d68472d84490f5e17 (patch)
tree61820bff343d1446a59ae746a80b137507f736fa /net/asterisk16/Makefile
parentbb16352d3172975fb6969fc1ede952980310fb7f (diff)
downloadfreebsd-ports-gnome-7defe680bea8d316c0358e1d68472d84490f5e17.tar.gz
freebsd-ports-gnome-7defe680bea8d316c0358e1d68472d84490f5e17.tar.zst
freebsd-ports-gnome-7defe680bea8d316c0358e1d68472d84490f5e17.zip
o Update to 1.4.20.1;
o add opt-in support for the iLBC codec; o move another extra patch into opt-in section.
Diffstat (limited to 'net/asterisk16/Makefile')
-rw-r--r--net/asterisk16/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index e73b65096aec..467e5d26a99a 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.4.19.2
-PORTREVISION= 1
+PORTVERSION= 1.4.20.1
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -51,6 +50,7 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
JABBER "Enable Jabber and Gtalk support" on \
SQLITE "Enable SQLITE support" on \
CODEC_PATCH "Apply codec negotiation patch" off \
+ ILBC "Enable iLBC codec" off \
MISC_PATCHES "Apply additional patches" off
.include <bsd.port.pre.mk>
@@ -159,6 +159,13 @@ CONFIGURE_ARGS+= --with-sqlite
LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
.endif
+.if defined(WITHOUT_ILBC)
+PLIST_SUB+= WITH_ILBC="@comment "
+.else
+PLIST_SUB+= WITH_ILBC=""
+EXTRA_PATCHES+= ${PATCHDIR}/ilbc_enable.diff
+.endif
+
.if defined(WITH_CODEC_PATCH)
PATCHFILES= asterisk-1.4.19-codec-negotiation-20080408.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
@@ -171,6 +178,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/nocodecnego-patch-Makefile
EXTRA_PATCHES+= ${PATCHDIR}/dtmf_debug.diff
EXTRA_PATCHES+= ${PATCHDIR}/feature_disconnect.diff
EXTRA_PATCHES+= ${PATCHDIR}/sip_force_callid.diff
+EXTRA_PATCHES+= ${PATCHDIR}/sip_set_auth.diff
.if defined(WITH_CODEC_PATCH)
EXTRA_PATCHES+= ${PATCHDIR}/rtp_force_dtmf-codecnego.diff
.else
@@ -178,6 +186,9 @@ EXTRA_PATCHES+= ${PATCHDIR}/rtp_force_dtmf-nocodecnego.diff
.endif
.endif
+post-extract:
+ ${MKDIR} ${WRKSRC}/codecs/ilbc
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample