aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk16/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-03-05 16:31:35 +0800
committerfjoe <fjoe@FreeBSD.org>2010-03-05 16:31:35 +0800
commitd95df01138e5c2592a6e2d92dfef443f0b5e1a74 (patch)
tree7adaa9c7e0e1ebb34baac2144e6602fc4f688c35 /net/asterisk16/Makefile
parent1810d5be7be48b7930480c9a19454b69ce3b0566 (diff)
downloadfreebsd-ports-gnome-d95df01138e5c2592a6e2d92dfef443f0b5e1a74.tar.gz
freebsd-ports-gnome-d95df01138e5c2592a6e2d92dfef443f0b5e1a74.tar.zst
freebsd-ports-gnome-d95df01138e5c2592a6e2d92dfef443f0b5e1a74.zip
Re-enable Zaptel (now DAHDI) support.
Approved by: MAINTAINER Feature safe: yes
Diffstat (limited to 'net/asterisk16/Makefile')
-rw-r--r--net/asterisk16/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index f986a03350d9..72b5c1bb0f85 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -60,12 +60,12 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
.include <bsd.port.pre.mk>
-#.if ${ARCH} == "i386" || ${ARCH} == "amd64"
-#OPTIONS+= ZAPTEL "Enable Zaptel support" off
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+OPTIONS+= DAHDI "Enable DAHDI support" on
# Include this since we have altered OPTIONS.
-#.include "$(PORTSDIR)/Mk/bsd.port.options.mk"
-#.endif
+.include "$(PORTSDIR)/Mk/bsd.port.options.mk"
+.endif
.if !defined(WITH_H323)
PLIST_SUB+= WITH_H323="@comment "
@@ -77,16 +77,16 @@ LIB_DEPENDS+= pt_r.1:${PORTSDIR}/devel/pwlib \
h323_r.1:${PORTSDIR}/net/openh323
.endif
-.if !defined(WITH_ZAPTEL)
-PLIST_SUB+= WITH_ZAPTEL="@comment "
-CONFIGURE_ARGS+= --without-zaptel
+.if !defined(WITH_DAHDI)
+PLIST_SUB+= WITH_DAHDI="@comment "
+CONFIGURE_ARGS+= --without-dahdi
.else
-PLIST_SUB+= WITH_ZAPTEL=""
-CONFIGURE_ARGS+= --with-zaptel
-BUILD_DEPENDS+= libpri>=1.2.0:${PORTSDIR}/misc/libpri \
- ${LOCALBASE}/include/zaptel/zaptel.h:${PORTSDIR}/misc/zaptel
+PLIST_SUB+= WITH_DAHDI=""
+CONFIGURE_ARGS+= --with-dahdi
+BUILD_DEPENDS+= libpri>=1.4.10:${PORTSDIR}/misc/libpri \
+ ${LOCALBASE}/include/dahdi/user.h:${PORTSDIR}/misc/dahdi
LIB_DEPENDS+= pri.1:${PORTSDIR}/misc/libpri
-RUN_DEPENDS+= ${LOCALBASE}/include/zaptel/zaptel.h:${PORTSDIR}/misc/zaptel
+RUN_DEPENDS+= ${LOCALBASE}/lib/dahdi/dahdi.ko:${PORTSDIR}/misc/dahdi
.endif
#