aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk16
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2005-08-29 22:12:28 +0800
committersobomax <sobomax@FreeBSD.org>2005-08-29 22:12:28 +0800
commitd112f700f3f52301ec0935392e4ca7b344d5810a (patch)
tree83671031f4a59e949dd0ae072a4e3c38dba41da1 /net/asterisk16
parentae793200d94317a4140854f3f55850fc03f1194a (diff)
downloadfreebsd-ports-gnome-d112f700f3f52301ec0935392e4ca7b344d5810a.tar.gz
freebsd-ports-gnome-d112f700f3f52301ec0935392e4ca7b344d5810a.tar.zst
freebsd-ports-gnome-d112f700f3f52301ec0935392e4ca7b344d5810a.zip
Make app_rxfax/app_txfax compilable on 4.x.
Diffstat (limited to 'net/asterisk16')
-rw-r--r--net/asterisk16/Makefile4
-rw-r--r--net/asterisk16/files/patch-apps::app_rxfax.c13
-rw-r--r--net/asterisk16/files/patch-apps::app_txfax.c13
3 files changed, 21 insertions, 9 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 60a8230c08cd..93e63cc0dc85 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -85,9 +85,7 @@ MAKE_ENV+= WITH_ODBC=1
USE_MYSQL= yes
.endif
-#
-# FAX apps can't be compiled on RELENG_4 at the moment
-.if defined(WITHOUT_FAX) || ${OSVERSION} < 500000
+.if defined(WITHOUT_FAX)
PLIST_SUB+= WITH_FAX="@comment "
.else
MAKE_ENV+= WITH_FAX=1
diff --git a/net/asterisk16/files/patch-apps::app_rxfax.c b/net/asterisk16/files/patch-apps::app_rxfax.c
index c8f4e3e296dc..88362bfc7914 100644
--- a/net/asterisk16/files/patch-apps::app_rxfax.c
+++ b/net/asterisk16/files/patch-apps::app_rxfax.c
@@ -1,6 +1,9 @@
---- apps/app_rxfax.c.orig Fri Jun 17 21:13:01 2005
-+++ apps/app_rxfax.c Fri Jun 17 21:04:12 2005
-@@ -0,0 +1,367 @@
+
+$FreeBSD$
+
+--- apps/app_rxfax.c.orig
++++ apps/app_rxfax.c
+@@ -0,0 +1,371 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -25,7 +28,11 @@
+#include <asterisk/manager.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <math.h>
diff --git a/net/asterisk16/files/patch-apps::app_txfax.c b/net/asterisk16/files/patch-apps::app_txfax.c
index 52bcc3fdde23..8daf0f979334 100644
--- a/net/asterisk16/files/patch-apps::app_txfax.c
+++ b/net/asterisk16/files/patch-apps::app_txfax.c
@@ -1,6 +1,9 @@
---- apps/app_txfax.c.orig Fri Jun 17 21:13:05 2005
-+++ apps/app_txfax.c Fri Jun 17 21:00:43 2005
-@@ -0,0 +1,289 @@
+
+$FreeBSD$
+
+--- apps/app_txfax.c.orig
++++ apps/app_txfax.c
+@@ -0,0 +1,293 @@
+/*
+ * Asterisk -- A telephony toolkit for Linux.
+ *
@@ -23,7 +26,11 @@
+#include <asterisk/translate.h>
+#include <string.h>
+#include <stdlib.h>
++#if defined(__FreeBSD__) && __FreeBSD_version < 500028
++#include <inttypes.h>
++#else
+#include <stdint.h>
++#endif
+#include <pthread.h>
+#include <errno.h>
+#include <tiffio.h>