aboutsummaryrefslogtreecommitdiffstats
path: root/net/avahi/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-01-30 02:47:31 +0800
committermarcus <marcus@FreeBSD.org>2006-01-30 02:47:31 +0800
commit95f470a252b873e5a164148be142e004ce200108 (patch)
tree1035f60e290d2f2fe9ffd0a8bc67fc5cbbb69281 /net/avahi/Makefile
parent47ed7a8f56304f7e7a05e6abfb93c7862faca2a9 (diff)
downloadfreebsd-ports-gnome-95f470a252b873e5a164148be142e004ce200108.tar.gz
freebsd-ports-gnome-95f470a252b873e5a164148be142e004ce200108.tar.zst
freebsd-ports-gnome-95f470a252b873e5a164148be142e004ce200108.zip
In trying to solve a problem with inconsistencies when linking with -shared
and ${PTHREAD_LIBS}, avahi linked its binaries with -lc_r on FreeBSD. This caused nasty runtime failures on i386, and build failures on alpha, amd64, and other platforms where libc_r no longer exists. To fix this, don't go through the song and dance of trying to solve the -shared/${PTHREAD_LIBS} problem, and just link with ${PTHREAD_LIBS} as usual. Of course, ports that depend on avahi's libraries will break by doing this, so add ${PTHREAD_{LIBS,CFLAGS}} to the right pkg-config files to make sure dependencies will pick them up. Patch adapted from: Yasuda Keisuke <kysd@po.harenet.ne.jp>
Diffstat (limited to 'net/avahi/Makefile')
-rw-r--r--net/avahi/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 7c2be562587b..f322477d4fec 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= avahi
PORTVERSION= 0.6.5
+PORTREVISION= 1
CATEGORIES= net dns
MASTER_SITES= http://www.avahi.org/download/
@@ -33,7 +34,9 @@ CONFIGURE_ARGS= --with-distro=freebsd \
--disable-doxygen-dot \
--localstatedir=/var
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
USE_RC_SUBR= yes