aboutsummaryrefslogtreecommitdiffstats
path: root/net/avahi/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-06-11 03:14:04 +0800
committermarcus <marcus@FreeBSD.org>2006-06-11 03:14:04 +0800
commited3a153959813c03958d39a408e0b5d2f8c18b29 (patch)
treebfbebcb196f1ba741113eba02e78d9a4ff7bcb50 /net/avahi/Makefile
parentee6c5b1b136a3d750112c716488641fe585dacdd (diff)
downloadfreebsd-ports-gnome-ed3a153959813c03958d39a408e0b5d2f8c18b29.tar.gz
freebsd-ports-gnome-ed3a153959813c03958d39a408e0b5d2f8c18b29.tar.zst
freebsd-ports-gnome-ed3a153959813c03958d39a408e0b5d2f8c18b29.zip
Make libdns (aka mDNSResponder) support optional (defaulting to off).
Note: enabling this will add a conflict to mDNSResponder which may interfere with KDE applications. PR: 98566 Submitted by: Kirk Strauser <kirk@strauser.com> (with modifications)
Diffstat (limited to 'net/avahi/Makefile')
-rw-r--r--net/avahi/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 192e76fe7200..3e6018853ff5 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -48,7 +48,8 @@ MAN1= avahi-browse-domains.1 avahi-browse.1 avahi-publish-address.1 \
MAN5= avahi-daemon.conf.5 avahi.service.5 avahi.hosts.5
MAN8= avahi-daemon.8 avahi-dnsconfd.8 avahi-dnsconfd.action.8
-OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off
+OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off \
+ LIBDNS "Enable mDNSResponder compatibility" off
.endif
.include <bsd.port.pre.mk>
@@ -58,6 +59,15 @@ OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off
IGNORE= does not work on FreeBSD 4.X
.endif
+.if defined(WITH_LIBDNS)
+CONFIGURE_ARGS+=--enable-compat-libdns_sd
+PLIST_SUB+= LIBDNS=""
+CONFLICTS+= mDNSResponder-[0-9]*
+.else
+CONFIGURE_ARGS+=--disable-compat-libdns_sd
+PLIST_SUB+= LIBDNS="@comment "
+.endif
+
.if defined(WITH_GTK2)
USE_GNOME+= libglade2
PLIST_SUB+= GTK=""