aboutsummaryrefslogtreecommitdiffstats
path: root/net/azureus
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-01-15 01:29:11 +0800
committerlioux <lioux@FreeBSD.org>2005-01-15 01:29:11 +0800
commit886f69e7cc1e9b190c937c6ec8fdb288f4f70328 (patch)
treed6b42a35d311a3ec4ee0f322c2ceb555cca07aea /net/azureus
parent908ba6a954005dadc90efbc6df7c6c1286efb468 (diff)
downloadfreebsd-ports-gnome-886f69e7cc1e9b190c937c6ec8fdb288f4f70328.tar.gz
freebsd-ports-gnome-886f69e7cc1e9b190c937c6ec8fdb288f4f70328.tar.zst
freebsd-ports-gnome-886f69e7cc1e9b190c937c6ec8fdb288f4f70328.zip
1) FILESDIR/azureus: make sure azureus will save plugin updates
where it should; i.e., HOME/.Azureus/plugins. This will stop azureus from creating plugins dirs anywhere it is invoked (pwd). Issue with all versions of azureus including CVS 2) Remove swt-pi.jar eclipse dependency from BUILD_DEPENDS. It is still listed as RUN_DEPENDS 3) Bump PORTREVISION for [1]
Diffstat (limited to 'net/azureus')
-rw-r--r--net/azureus/Makefile4
-rw-r--r--net/azureus/files/azureus2
2 files changed, 3 insertions, 3 deletions
diff --git a/net/azureus/Makefile b/net/azureus/Makefile
index dd78176d02ba..e19859afb93a 100644
--- a/net/azureus/Makefile
+++ b/net/azureus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= azureus
PORTVERSION= 2.2.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,9 +17,9 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= A BitTorrent client written in Java
BUILD_DEPENDS= \
- ${LOCALBASE}/eclipse/plugins/org.eclipse.swt.gtk_${ECLIPSE_VERSION}/ws/gtk/swt-pi.jar:${PORTSDIR}/java/eclipse \
${LOCALBASE}/eclipse/plugins/org.eclipse.swt.gtk_${ECLIPSE_VERSION}/ws/gtk/swt.jar:${PORTSDIR}/java/eclipse
RUN_DEPENDS= \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.swt.gtk_${ECLIPSE_VERSION}/ws/gtk/swt-pi.jar:${PORTSDIR}/java/eclipse \
${BUILD_DEPENDS}
ONLY_FOR_ARCHS= i386
diff --git a/net/azureus/files/azureus b/net/azureus/files/azureus
index b58835467a73..2505948011a1 100644
--- a/net/azureus/files/azureus
+++ b/net/azureus/files/azureus
@@ -27,4 +27,4 @@ then
echo "LIB_PATH = ${LIB_PATH}"
fi
-exec "%%JAVA%%" -cp "${CLASS_PATH}" "-Djava.library.path=${LIB_PATH}" "-Dos.name=Linux" org.gudy.azureus2.ui.swt.Main "${@}"
+exec "%%JAVA%%" -cp "${CLASS_PATH}" "-Djava.library.path=${LIB_PATH}" "-Dos.name=Linux" "-Dazureus.config.path=${HOME}/.Azureus" "-Duser.dir=${HOME}/.Azureus" org.gudy.azureus2.ui.swt.Main "${@}"