aboutsummaryrefslogtreecommitdiffstats
path: root/net/beacon/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-07-12 04:06:33 +0800
committerthierry <thierry@FreeBSD.org>2004-07-12 04:06:33 +0800
commitd849f7fa144548c41be920d4afceb2580edbaed0 (patch)
tree53122d599250d23f53ddf3062334920111ef81d8 /net/beacon/Makefile
parentfa424d23c2ea50fc52dde5384cef6967a8e4208b (diff)
downloadfreebsd-ports-gnome-d849f7fa144548c41be920d4afceb2580edbaed0.tar.gz
freebsd-ports-gnome-d849f7fa144548c41be920d4afceb2580edbaed0.tar.zst
freebsd-ports-gnome-d849f7fa144548c41be920d4afceb2580edbaed0.zip
Upgrade to 0.9.55 and make fetchable again.
Submitted by: maintainer.
Diffstat (limited to 'net/beacon/Makefile')
-rw-r--r--net/beacon/Makefile34
1 files changed, 9 insertions, 25 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 4462eecb24a6..fb688b006f55 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= beacon
-PORTVERSION= 0.9.06
-PORTREVISION= 1
+PORTVERSION= 0.9.55
CATEGORIES= net perl5 mbone ipv6
-MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/Releases/
+MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/releases/
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Beacon active measurement tool to monitor multicast
@@ -17,10 +16,12 @@ COMMENT= Beacon active measurement tool to monitor multicast
BUILD_DEPENDS= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= "Unfetchable"
-
WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
+USE_PERL5= yes
+USE_AUTOCONF_VER= 259
+CONFIGURE_ARGS= --enable-ipv6 --bindir=${WWW_DIR}/${PORTNAME}-${PORTVERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.pre.mk>
@@ -28,30 +29,13 @@ PLIST_SUB+= VERSION=${PORTVERSION}
IGNORE= Port requires perl 5.6.1 or later. Install lang/perl5 then try again
.endif
-do-build:
- #Build unreleased NET::RTP perl module
- cd ${WRKSRC}/Net-RTP-0.4/ ; \
- ./configure --enable-ipv6 ; \
- ${PERL} Makefile.PL ; \
- make
-
-do-install:
- #Install unreleased NET::RTP perl module
- cd ${WRKSRC}/Net-RTP-0.4/ ; \
- make install
- #Install the Beacon itself
- ${MKDIR} ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
- ${INSTALL_SCRIPT} ${WRKSRC}/beacon.pl ${WWW_DIR}/${PORTNAME}-${PORTVERSION}
- ${INSTALL_DATA} ${WRKSRC}/beacon.conf ${PREFIX}/etc/beacon.conf.sample
- @${ECHO} ""
+post-install:
@${ECHO} "Sample config installed at \
- ${PREFIX}/etc/beacon.conf.sample"
+ ${PREFIX}/etc/beacon.conf.sample"
@${ECHO} "Copy the customised version to ${PREFIX}/etc/beacon.conf"
-
.ifndef(NOPORTDOCS)
-post-install:
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.post.mk>