aboutsummaryrefslogtreecommitdiffstats
path: root/net/bind8/Makefile
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2002-01-21 19:05:59 +0800
committerdougb <dougb@FreeBSD.org>2002-01-21 19:05:59 +0800
commit3e72f62c145eeab8a2457f313a0272e41f289f5a (patch)
tree4e7f1f2c754a1890db9797bd1e8dd67473f5e594 /net/bind8/Makefile
parentb96371091804e800d146f17a2a4567cbbe958486 (diff)
downloadfreebsd-ports-gnome-3e72f62c145eeab8a2457f313a0272e41f289f5a.tar.gz
freebsd-ports-gnome-3e72f62c145eeab8a2457f313a0272e41f289f5a.tar.zst
freebsd-ports-gnome-3e72f62c145eeab8a2457f313a0272e41f289f5a.zip
Upgrade to version 8.3.0, which contains bug fixes too numerous to mention,
and a few new features. Many of the bugs are related to memory allocation, and some of BIND's newer features like TSIG, IXFR, etc. Users particularly interested should take a look at the CHANGES file (see below). Perhaps the most significant change is the introduction of EDNS0, the ability to negotiate capabilities between servers. This feature was previously only available in BIND 9. Whether this is a good idea or not is yet to be seen. Install more of the documentation, and wrap it all in PORTSDOCS.
Diffstat (limited to 'net/bind8/Makefile')
-rw-r--r--net/bind8/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/net/bind8/Makefile b/net/bind8/Makefile
index 0a885a653df4..a4fcdcd812bd 100644
--- a/net/bind8/Makefile
+++ b/net/bind8/Makefile
@@ -11,7 +11,7 @@
# you can generally build it cleanly from the source. - Doug
PORTNAME= bind
-PORTVERSION= 8.2.5
+PORTVERSION= 8.3.0
CATEGORIES?= net
MASTER_SITES= ftp://ftp.isc.org/isc/bind/src/${PORTVERSION}/ \
ftp://ftp.epix.net/pub/isc/bind/src/${PORTVERSION}/ \
@@ -36,8 +36,15 @@ PATCH_ARGS= -d ${WRKDIR}
PATCH_DIST_ARGS= -d ${WRKDIR}
post-install:
- @(cd ${WRKDIR}/doc/man && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} clean all ${INSTALL_TARGET})
- ${MKDIR} ${PREFIX}/share/doc/bind8
- ${INSTALL_DATA} ${WRKDIR}/doc/html/*.html ${PREFIX}/share/doc/bind8
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKDIR}/doc/man && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} clean all ${INSTALL_TARGET})
+ @${MKDIR} ${PREFIX}/share/doc/bind8/html
+ ${INSTALL_DATA} ${WRKDIR}/doc/html/*.html ${PREFIX}/share/doc/bind8/html
+ ${CP} -Rp ${WRKDIR}/src/conf ${PREFIX}/share/doc/bind8/
+.for file in CHANGES DNSSEC LICENSE LICENSE_RSA README SUPPORT TODO
+ ${INSTALL_DATA} ${WRKDIR}/src/${file} ${PREFIX}/share/doc/bind8
+.endfor
+.endif
.include <bsd.port.mk>