aboutsummaryrefslogtreecommitdiffstats
path: root/net/bird-devel
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2011-11-08 17:44:29 +0800
committersem <sem@FreeBSD.org>2011-11-08 17:44:29 +0800
commit022218045e56b9ae579c3e82819b62f6f4d9cc28 (patch)
tree78dc5f3455c94c679a9357e936ab745017a3abe3 /net/bird-devel
parentcbdda83f40282c36643ef3916037741e94285898 (diff)
downloadfreebsd-ports-gnome-022218045e56b9ae579c3e82819b62f6f4d9cc28.tar.gz
freebsd-ports-gnome-022218045e56b9ae579c3e82819b62f6f4d9cc28.tar.zst
freebsd-ports-gnome-022218045e56b9ae579c3e82819b62f6f4d9cc28.zip
* New port:
This is development version of net/bird dynamic routing software. It provides ALPHA support for the following: - VPNv4 RR - LDP - L3VPN Submitted by: melifaro
Diffstat (limited to 'net/bird-devel')
-rw-r--r--net/bird-devel/Makefile52
-rw-r--r--net/bird-devel/distinfo2
-rw-r--r--net/bird-devel/files/bird.in32
-rw-r--r--net/bird-devel/files/patch-tools-Makefile.in15
-rw-r--r--net/bird-devel/files/patch-tools-Rules.in13
-rw-r--r--net/bird-devel/pkg-descr16
-rw-r--r--net/bird-devel/pkg-plist5
7 files changed, 135 insertions, 0 deletions
diff --git a/net/bird-devel/Makefile b/net/bird-devel/Makefile
new file mode 100644
index 000000000000..ab98e9de496d
--- /dev/null
+++ b/net/bird-devel/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: bird
+# Date created: 8 November 2011
+# Whom: Alexander V. Chernikov <melifaro@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bird
+PORTVERSION= 20111107
+CATEGORIES= net
+MASTER_SITES= http://bird.mpls.in/distfiles/bird/
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= melifaro@ipfw.ru
+COMMENT= Dynamic IP routing daemon (devel version)
+
+CONFLICTS= bird-[0-9]*
+
+USE_BISON= build
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-mpls
+
+OPTIONS= KMPLS "Enable kernel MPLS support" Off
+
+MAKE_JOBS_UNSAFE= yes
+
+USE_RC_SUBR= bird
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_KMPLS)
+CONFIGURE_ARGS+= --enable-kmpls
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
+ ${CHMOD} 0640 ${PREFIX}/etc/bird.conf ; \
+ fi
+ @${ECHO_MSG}
+ @${ECHO_MSG} =====================================================================
+ @${ECHO_MSG}
+ @${ECHO_MSG} " WARNING: Please take a look on kern/134931"
+ @${ECHO_MSG} " WARNING: before using multiple fibs!"
+ @${ECHO_MSG} " 8.2-STABLE kernel patch available here:"
+ @${ECHO_MSG} " http://static.ipfw.ru/patches/rtsock_82S-20110725.diff"
+ @${ECHO_MSG}
+ @${ECHO_MSG} =====================================================================
+ @${ECHO_MSG}
+
+.include <bsd.port.post.mk>
diff --git a/net/bird-devel/distinfo b/net/bird-devel/distinfo
new file mode 100644
index 000000000000..61959fe425c4
--- /dev/null
+++ b/net/bird-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bird-20111107.tar.gz) = b8dfa1869cae81fae493b3596d4b038a27e72c2d73d3be7b961c9b636333e79e
+SIZE (bird-20111107.tar.gz) = 3512093
diff --git a/net/bird-devel/files/bird.in b/net/bird-devel/files/bird.in
new file mode 100644
index 000000000000..68dc9bd27141
--- /dev/null
+++ b/net/bird-devel/files/bird.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: bird
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bird_enable (bool): Set to NO by default.
+# Set it to YES to enable bird.
+# bird_config (path): Set to %%PREFIX%%/etc/bird.conf
+# by default.
+#
+
+. /etc/rc.subr
+
+name="bird"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/${name}
+
+load_rc_config $name
+
+: ${bird_enable="NO"}
+: ${bird_config="%%PREFIX%%/etc/bird.conf"}
+
+command_args="-c $bird_config"
+
+run_rc_command "$1"
diff --git a/net/bird-devel/files/patch-tools-Makefile.in b/net/bird-devel/files/patch-tools-Makefile.in
new file mode 100644
index 000000000000..51fa404385f6
--- /dev/null
+++ b/net/bird-devel/files/patch-tools-Makefile.in
@@ -0,0 +1,15 @@
+--- tools/Makefile.in.orig 2009-08-16 22:42:37.000000000 +0200
++++ tools/Makefile.in 2009-09-16 22:22:07.000000000 +0200
+@@ -60,11 +60,7 @@
+ if test -n "@CLIENT@" ; then \
+ $(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
+ fi
+- if ! test -f $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; then \
+- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; \
+- else \
+- echo "Not overwriting old bird@SUFFIX@.conf" ; \
+- fi
++ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf.example ; \
+
+ install-docs:
+ $(INSTALL) -d $(DESTDIR)/$(docdir)
diff --git a/net/bird-devel/files/patch-tools-Rules.in b/net/bird-devel/files/patch-tools-Rules.in
new file mode 100644
index 000000000000..cb7af39da430
--- /dev/null
+++ b/net/bird-devel/files/patch-tools-Rules.in
@@ -0,0 +1,13 @@
+--- tools/Rules.in.orig 2010-10-10 21:48:20.000000000 +0200
++++ tools/Rules.in 2010-12-18 15:00:27.000000000 +0100
+@@ -66,9 +66,7 @@
+ subdir: all.o
+
+ all.o: $(objs)
+-# $(LD) -r -o $@ $^
+-# Changed to $(CC) because $(LD) has problems with crosscompiling
+- $(CC) -nostdlib -r -o $@ $^
++ $(LD) -r -o $@ $^
+
+ endif
+
diff --git a/net/bird-devel/pkg-descr b/net/bird-devel/pkg-descr
new file mode 100644
index 000000000000..1a88347c52f3
--- /dev/null
+++ b/net/bird-devel/pkg-descr
@@ -0,0 +1,16 @@
+The BIRD project aims to develop a fully functional dynamic IP routing daemon.
+
+- Both IPv4 and IPv6
+- Multiple routing tables
+- BGP
+- RIP
+- OSPF
+- LDP
+- L3VPN
+- Static routes
+- Inter-table protocol
+- Command-line interface
+- Soft reconfiguration
+- Powerful language for route filtering
+
+WWW: http://bird.mpls.in/
diff --git a/net/bird-devel/pkg-plist b/net/bird-devel/pkg-plist
new file mode 100644
index 000000000000..ec18be838b66
--- /dev/null
+++ b/net/bird-devel/pkg-plist
@@ -0,0 +1,5 @@
+@unexec if cmp -s %D/etc/bird.conf.example %D/etc/bird.conf; then rm -f %D/etc/bird.conf; fi
+etc/bird.conf.example
+@exec if [ ! -f %D/etc/bird.conf ] ; then cp -p %D/%F %B/bird.conf; fi
+sbin/bird
+sbin/birdc