aboutsummaryrefslogtreecommitdiffstats
path: root/net/bird
diff options
context:
space:
mode:
authormelifaro <melifaro@FreeBSD.org>2014-12-06 22:14:51 +0800
committermelifaro <melifaro@FreeBSD.org>2014-12-06 22:14:51 +0800
commitfc982555de44ef6208eb6118672c07091742dda8 (patch)
tree4f2ef5033d765c041cffcc98d6efcab76b332549 /net/bird
parent59bda459fbc8994ec7be71062095fa2018371643 (diff)
downloadfreebsd-ports-gnome-fc982555de44ef6208eb6118672c07091742dda8.tar.gz
freebsd-ports-gnome-fc982555de44ef6208eb6118672c07091742dda8.tar.zst
freebsd-ports-gnome-fc982555de44ef6208eb6118672c07091742dda8.zip
Increase max symbol length: 32->64
Approved by: az(implicit)
Diffstat (limited to 'net/bird')
-rw-r--r--net/bird/Makefile1
-rw-r--r--net/bird/files/patch-conf-cf-lex.l11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index 6357cdbea6d3..47e5dcb6a219 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -3,6 +3,7 @@
PORTNAME?= bird
PORTVERSION= 1.4.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/ \
http://bird.mpls.in/distfiles/bird/
diff --git a/net/bird/files/patch-conf-cf-lex.l b/net/bird/files/patch-conf-cf-lex.l
new file mode 100644
index 000000000000..89600e04e467
--- /dev/null
+++ b/net/bird/files/patch-conf-cf-lex.l
@@ -0,0 +1,11 @@
+--- conf/cf-lex.l.orig 2014-12-06 17:10:24.000000000 +0300
++++ conf/cf-lex.l 2014-12-06 17:10:41.000000000 +0300
+@@ -61,7 +61,7 @@
+ static int kw_hash_inited;
+
+ #define SYM_HASH_SIZE 128
+-#define SYM_MAX_LEN 32
++#define SYM_MAX_LEN 64
+
+ struct sym_scope {
+ struct sym_scope *next; /* Next on scope stack */