aboutsummaryrefslogtreecommitdiffstats
path: root/net/blam
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-03-21 12:53:12 +0800
committermezz <mezz@FreeBSD.org>2005-03-21 12:53:12 +0800
commitc91b17b07ab3cf4e0947a4f36d607dcf263641b2 (patch)
tree1f70f042bbff1469ad0b0a638a2aeadc1900b557 /net/blam
parentd0ca851133319c4d720f1c29ac0e7cc30e4c72d1 (diff)
downloadfreebsd-ports-gnome-c91b17b07ab3cf4e0947a4f36d607dcf263641b2.tar.gz
freebsd-ports-gnome-c91b17b07ab3cf4e0947a4f36d607dcf263641b2.tar.zst
freebsd-ports-gnome-c91b17b07ab3cf4e0947a4f36d607dcf263641b2.zip
Add WITH_MOZILLA knob to support build with firefox, mozilla is default. As
for thunderbird and mozilla-devel, I am not going to add them without test. If anyone want/need, then send tmclaugh or me patch(es). Approved by: tmclaugh (maintainer) in #freebsd-gnome (irc.freenode.net)
Diffstat (limited to 'net/blam')
-rw-r--r--net/blam/Makefile22
1 files changed, 20 insertions, 2 deletions
diff --git a/net/blam/Makefile b/net/blam/Makefile
index 6431c7839b76..60a38137dfdf 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -8,7 +8,7 @@
PORTNAME= blam
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.6
@@ -20,15 +20,33 @@ BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp \
${X11BASE}/libdata/pkgconfig/gecko-sharp.pc:${PORTSDIR}/www/gecko-sharp
RUN_DEPENDS= ${BUILD_DEPENDS}
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla
+.else
+.if ${WITH_MOZILLA}=="firefox"
+MOZILLA= firefox
+.else
+MOZILLA= mozilla
+.endif
+.endif
+
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
USE_GMAKE= yes
-
+CONFIGURE_ARGS= --with-mozilla=${MOZILLA}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= blam.schemas
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} ""
+
.include <bsd.port.mk>