aboutsummaryrefslogtreecommitdiffstats
path: root/net/bld/Makefile
diff options
context:
space:
mode:
authorjmelo <jmelo@FreeBSD.org>2006-06-01 01:50:06 +0800
committerjmelo <jmelo@FreeBSD.org>2006-06-01 01:50:06 +0800
commit5f643ac51c7eec2a8645b16a2089d3533589af2a (patch)
tree0989958cc557550132e58212b3879a14bef297c9 /net/bld/Makefile
parent5993eac0691ef14a3afb041a06b226d4ef1dca7d (diff)
downloadfreebsd-ports-gnome-5f643ac51c7eec2a8645b16a2089d3533589af2a.tar.gz
freebsd-ports-gnome-5f643ac51c7eec2a8645b16a2089d3533589af2a.tar.zst
freebsd-ports-gnome-5f643ac51c7eec2a8645b16a2089d3533589af2a.zip
- Update to 0.3.4.
- Unbreak on 4.X. - Update to use new USE_RC_SUBR style. PR: ports/96266 Submitted by: Olivier Beyssac <obld@r14.freenix.org> (maintainer) Reworked by: mnag, jmelo Approved by: mnag (mentor)
Diffstat (limited to 'net/bld/Makefile')
-rw-r--r--net/bld/Makefile20
1 files changed, 5 insertions, 15 deletions
diff --git a/net/bld/Makefile b/net/bld/Makefile
index af0f2c8d8739..62db7566e4b5 100644
--- a/net/bld/Makefile
+++ b/net/bld/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= bld
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
CATEGORIES= net
MASTER_SITES= http://www.online.redhate.org/bld/
MAINTAINER= obld@r14.freenix.org
COMMENT= A blacklisting daemon
-USE_RC_SUBR= yes
+USE_RC_SUBR= bld
MANCOMPRESSED= yes
GNU_CONFIGURE= yes
+USE_GCC= 3.2+
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/bld
PORTDOCS= README README.postfix
@@ -24,16 +25,7 @@ MAN8= bldsubmit.8 bld.8 bldquery.8 bldread.8 bldinsert.8 blddecr.8 \
bld-pf_policy.8 bld-pf_log.pl.8 bld-mrtg.pl.8 \
bld-will_spam_for_food.pl.8
-SED_SCRIPT= -e 's|%%PREFIX%%|${PREFIX}|g'
-RC_DIR= ${PREFIX}/etc/rc.d
-RC_SUFX= .sh
-SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
- -e 's|%%RC_DIR%%|${RC_DIR}|g' \
- -e 's|%%RC_SUFX%%|${RC_SUFX}|g'
-
-post-build:
- ${SED} ${SED_SCRIPT} ${FILESDIR}/bld.sh \
- >${WRKDIR}/bld.sh
+.include <bsd.port.pre.mk>
post-install:
.if !defined(NOPORTDOCS)
@@ -42,8 +34,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
- @${INSTALL_SCRIPT} ${WRKDIR}/bld.sh \
- ${RC_DIR}/bld${RC_SUFX}
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>