aboutsummaryrefslogtreecommitdiffstats
path: root/net/boinc-client
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-29 18:46:23 +0800
committerpav <pav@FreeBSD.org>2006-04-29 18:46:23 +0800
commit163b2481189cdc7d4f5b36428145655fb9abb7da (patch)
tree818967e58fe7caa36fc832bb75f5660d906bf485 /net/boinc-client
parent87e5072a679f676e60ab331d43fc8b8259c8d3e6 (diff)
downloadfreebsd-ports-gnome-163b2481189cdc7d4f5b36428145655fb9abb7da.tar.gz
freebsd-ports-gnome-163b2481189cdc7d4f5b36428145655fb9abb7da.tar.zst
freebsd-ports-gnome-163b2481189cdc7d4f5b36428145655fb9abb7da.zip
- Update to 5.4.7
Diffstat (limited to 'net/boinc-client')
-rw-r--r--net/boinc-client/Makefile2
-rw-r--r--net/boinc-client/distinfo6
-rw-r--r--net/boinc-client/files/patch-fix_anonymous_platform_attach41
-rw-r--r--net/boinc-client/files/patch-prefer_new_libs_over_installed4
4 files changed, 14 insertions, 39 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index dab41039c507..e4836f3427cc 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= boinc-client
-PORTVERSION= 5.2.15
+PORTVERSION= 5.4.7
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
diff --git a/net/boinc-client/distinfo b/net/boinc-client/distinfo
index 290a9bb31f20..dca2c2de62ae 100644
--- a/net/boinc-client/distinfo
+++ b/net/boinc-client/distinfo
@@ -1,3 +1,3 @@
-MD5 (boinc-client-5.2.15.tar.bz2) = 37eb7dbd2eb2c2d6becb0026e58d22d6
-SHA256 (boinc-client-5.2.15.tar.bz2) = 6cd4ae648c57ac05977820a1c4c8126abb5284361f62fdd06656b07b37b25325
-SIZE (boinc-client-5.2.15.tar.bz2) = 1987217
+MD5 (boinc-client-5.4.7.tar.bz2) = 21fe0ae1b0bca052bd4c7ee7367abad9
+SHA256 (boinc-client-5.4.7.tar.bz2) = 72064628d874f5fb198b170ca11ce61dcd5d505fad051bdf3c674e6a6e8cf169
+SIZE (boinc-client-5.4.7.tar.bz2) = 2511303
diff --git a/net/boinc-client/files/patch-fix_anonymous_platform_attach b/net/boinc-client/files/patch-fix_anonymous_platform_attach
index 780b54470018..cbf5bce667d9 100644
--- a/net/boinc-client/files/patch-fix_anonymous_platform_attach
+++ b/net/boinc-client/files/patch-fix_anonymous_platform_attach
@@ -1,33 +1,10 @@
---- client/cs_account.C.orig Mon Oct 3 20:05:58 2005
-+++ client/cs_account.C Wed Mar 8 18:41:37 2006
-@@ -346,7 +346,7 @@
- }
-
- int CLIENT_STATE::add_project(const char* master_url, const char* _auth) {
-- char path[256], canonical_master_url[256], auth[256];
-+ char path[256], canonical_master_url[256], auth[256], dir[256];
- PROJECT* project;
- FILE* f;
- int retval;
-@@ -366,7 +366,7 @@
- return ERR_AUTHENTICATOR;
- }
-
-- // check if this project is already running
-+ // check if we're already attached to this project
+--- client/cs_account.C.orig Fri Mar 3 22:34:00 2006
++++ client/cs_account.C Wed Apr 12 10:58:15 2006
+@@ -403,7 +403,14 @@
//
- if (lookup_project(canonical_master_url)) {
- msg_printf(0, MSG_ERROR, "Already attached to %s", canonical_master_url);
-@@ -392,8 +392,21 @@
- if (retval) return retval;
-
- // remove any old files
-+ // (unless PROJECT/app_info.xml is found, so that
-+ // people using anonymous platform don't have to get apps again)
- //
-- retval = remove_project_dir(*project);
-+ get_project_dir(project, dir);
-+ sprintf(path, "%s/%s", dir, APP_INFO_FILE_NAME);
+ get_project_dir(project, dir);
+ sprintf(path, "%s/%s", dir, APP_INFO_FILE_NAME);
+- if (!boinc_file_exists(path)) {
+ if (boinc_file_exists(path)) {
+ project->anonymous_platform = true;
+ f = fopen(path, "r");
@@ -36,8 +13,6 @@
+ fclose(f);
+ }
+ } else {
-+ retval = remove_project_dir(*project);
-+ }
+ retval = remove_project_dir(*project);
+ }
- retval = make_project_dir(*project);
- if (retval) return retval;
diff --git a/net/boinc-client/files/patch-prefer_new_libs_over_installed b/net/boinc-client/files/patch-prefer_new_libs_over_installed
index 1aa754a377b4..6e7f8b1be1a5 100644
--- a/net/boinc-client/files/patch-prefer_new_libs_over_installed
+++ b/net/boinc-client/files/patch-prefer_new_libs_over_installed
@@ -5,7 +5,7 @@
AM_CFLAGS = $(AM_CPPFLAGS)
AM_CXXFLAGS = $(AM_CPPFLAGS)
-AM_LDFLAGS =
-+AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/db -L$(top_srcdir)/client -L$(top_srcdir)/tools -L$(top_srcdir)/sched
++AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/client
# dependencies to make sure libs gets compiled before
# programs linking to them:
@@ -16,7 +16,7 @@
AM_CFLAGS = $(AM_CPPFLAGS)
AM_CXXFLAGS = $(AM_CPPFLAGS)
-AM_LDFLAGS =
-+AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/db -L$(top_srcdir)/client -L$(top_srcdir)/tools -L$(top_srcdir)/sched
++AM_LDFLAGS = -L$(top_srcdir)/lib -L$(top_srcdir)/api -L$(top_srcdir)/client
# dependencies to make sure libs gets compiled before
# programs linking to them: