aboutsummaryrefslogtreecommitdiffstats
path: root/net/boinc-client
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-27 17:36:57 +0800
committermarino <marino@FreeBSD.org>2014-07-27 17:36:57 +0800
commit7464db5042f61490f2ad7928bf119cace5d2a738 (patch)
tree28575bf22e4245e43bdbe863009c39f609678d40 /net/boinc-client
parent9b4705832a2386c633164f0b138764ffe9f7d851 (diff)
downloadfreebsd-ports-gnome-7464db5042f61490f2ad7928bf119cace5d2a738.tar.gz
freebsd-ports-gnome-7464db5042f61490f2ad7928bf119cace5d2a738.tar.zst
freebsd-ports-gnome-7464db5042f61490f2ad7928bf119cace5d2a738.zip
net/boinc-client: Fix to detect virtualbox again
The virtualbox path detection code has been patched to work on FreeBSD. The PR submission was modified to avoid hardcoding /usr/local. PR: 188710 Submitted by: Lawrence Chen
Diffstat (limited to 'net/boinc-client')
-rw-r--r--net/boinc-client/Makefile6
-rw-r--r--net/boinc-client/files/patch-client__hostinfo_unix.cpp20
2 files changed, 25 insertions, 1 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index ae7d1b97c7dc..9ed262437be8 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -3,7 +3,7 @@
PORTNAME= boinc-client
PORTVERSION= 7.2.33
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://rene-ladan.nl/pub/distfiles/
@@ -124,6 +124,10 @@ post-extract:
${WRKSRC}/zip/zip/zip.c ${WRKSRC}/zip/zip/zipfile.c \
${WRKSRC}/zip/zip/zipup.c
+post-patch:
+ ${REINPLACE_CMD} -e 's|@PREFIX@|${PREFIX}|' \
+ ${WRKSRC}/client/hostinfo_unix.cpp
+
pre-configure:
(cd ${WRKSRC} ; ./_autosetup)
diff --git a/net/boinc-client/files/patch-client__hostinfo_unix.cpp b/net/boinc-client/files/patch-client__hostinfo_unix.cpp
new file mode 100644
index 000000000000..0b63fa6a281f
--- /dev/null
+++ b/net/boinc-client/files/patch-client__hostinfo_unix.cpp
@@ -0,0 +1,20 @@
+--- client/hostinfo_unix.cpp.orig 2013-12-20 14:28:08.000000000 -0600
++++ client/hostinfo_unix.cpp 2014-04-16 17:07:56.996236131 -0500
+@@ -1213,6 +1213,8 @@
+
+ #if LINUX_LIKE_SYSTEM
+ safe_strcpy(path, "/usr/lib/virtualbox/VBoxManage");
++#elif defined( __FreeBSD__)
++ safe_strcpy(path, "@PREFIX@/lib/virtualbox/VBoxManage");
+ #elif defined( __APPLE__)
+ FSRef theFSRef;
+ OSStatus status = noErr;
+@@ -1231,7 +1233,7 @@
+ #endif
+
+ if (boinc_file_exists(path)) {
+-#if LINUX_LIKE_SYSTEM
++#if LINUX_LIKE_SYSTEM || defined( __FreeBSD__)
+ if (access(path, X_OK)) {
+ return 0;
+ }