aboutsummaryrefslogtreecommitdiffstats
path: root/net/boinc-client
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-08-06 16:29:56 +0800
committerpav <pav@FreeBSD.org>2008-08-06 16:29:56 +0800
commit894ebe8a59fea61187c3058438eeee6ca48b335d (patch)
treedbcd1dcda62d1b975d2408f7c1713bcf42e88a0b /net/boinc-client
parentc7e7d30a5f8daa020517ee974bfb50deb2be1123 (diff)
downloadfreebsd-ports-gnome-894ebe8a59fea61187c3058438eeee6ca48b335d.tar.gz
freebsd-ports-gnome-894ebe8a59fea61187c3058438eeee6ca48b335d.tar.zst
freebsd-ports-gnome-894ebe8a59fea61187c3058438eeee6ca48b335d.zip
- Update to 6.2.14
Diffstat (limited to 'net/boinc-client')
-rw-r--r--net/boinc-client/Makefile3
-rw-r--r--net/boinc-client/distinfo6
-rw-r--r--net/boinc-client/files/patch-CPUID80
-rw-r--r--net/boinc-client/files/patch-fix_anonymous_platform_attach18
-rw-r--r--net/boinc-client/files/patch-lib_util.C10
-rw-r--r--net/boinc-client/pkg-plist8
6 files changed, 6 insertions, 119 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 2d669ddf7127..a80735c2f564 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= boinc-client
-PORTVERSION= 5.10.32
-PORTREVISION= 2
+PORTVERSION= 6.2.14
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
diff --git a/net/boinc-client/distinfo b/net/boinc-client/distinfo
index 2cd7369d488b..7f48e5577ac1 100644
--- a/net/boinc-client/distinfo
+++ b/net/boinc-client/distinfo
@@ -1,3 +1,3 @@
-MD5 (boinc-client-5.10.32.tar.bz2) = 0718535f78c4097b8e3fb740b7d423d3
-SHA256 (boinc-client-5.10.32.tar.bz2) = 7d3570a0de643b9623731eea45df5601e046504865946c033fc08e2273940c60
-SIZE (boinc-client-5.10.32.tar.bz2) = 4022383
+MD5 (boinc-client-6.2.14.tar.bz2) = 547b704a2f393b4d75277270975bf322
+SHA256 (boinc-client-6.2.14.tar.bz2) = 20639ebaf4173d0fe7fa988fea368e540a0b4c7dd2ee25a46f36de6ce112008e
+SIZE (boinc-client-6.2.14.tar.bz2) = 4246362
diff --git a/net/boinc-client/files/patch-CPUID b/net/boinc-client/files/patch-CPUID
deleted file mode 100644
index c97768e4b0c0..000000000000
--- a/net/boinc-client/files/patch-CPUID
+++ /dev/null
@@ -1,80 +0,0 @@
---- client/hostinfo_unix.C.orig 2007-12-28 19:59:40.000000000 +0100
-+++ client/hostinfo_unix.C 2007-12-28 20:36:26.000000000 +0100
-@@ -451,6 +451,50 @@
- }
- #endif // linux
-
-+#ifdef __FreeBSD__
-+#if defined(__i386__) || defined(__amd64__)
-+#include <sys/types.h>
-+#include <sys/cdefs.h>
-+#include <machine/cpufunc.h>
-+
-+void use_cpuid(HOST_INFO& host) {
-+ u_int p[4];
-+ int hasMMX, hasSSE, hasSSE2, hasSSE3, has3DNow, has3DNowExt = 0;
-+ char capabilities[256];
-+
-+ do_cpuid(0x0, p);
-+
-+ if (p[0] >= 0x1) {
-+
-+ do_cpuid(0x1, p);
-+
-+ hasMMX = (p[3] & (1 << 23 )) >> 23; // 0x0800000
-+ hasSSE = (p[3] & (1 << 25 )) >> 25; // 0x2000000
-+ hasSSE2 = (p[3] & (1 << 26 )) >> 26; // 0x4000000
-+ hasSSE3 = (p[2] & (1 << 0 )) >> 0;
-+ }
-+
-+ do_cpuid(0x80000000, p);
-+ if (p[0]>=0x80000001) {
-+ do_cpuid(0x80000001, p);
-+ hasMMX |= (p[3] & (1 << 23 )) >> 23; // 0x0800000
-+ has3DNow = (p[3] & (1 << 31 )) >> 31; //0x80000000
-+ has3DNowExt = (p[3] & (1 << 30 )) >> 30;
-+ }
-+
-+ capabilities[0] = '\0';
-+ if (hasSSE) strncat(capabilities, "sse ", 4);
-+ if (hasSSE2) strncat(capabilities, "sse2 ", 5);
-+ if (hasSSE3) strncat(capabilities, "sse3 ", 5);
-+ if (has3DNow) strncat(capabilities, "3dnow ", 6);
-+ if (has3DNowExt) strncat(capabilities, "3dnowext ", 9);
-+ if (hasMMX) strncat(capabilities, "mmx ", 4);
-+ strip_whitespace(capabilities);
-+ snprintf(host.p_model, sizeof(host.p_model), "%s [] [%s]", host.p_model, capabilities);
-+}
-+#endif
-+#endif
-+
- #ifdef __APPLE__
- static void get_cpu_info_maxosx(HOST_INFO& host) {
- int p_model_size = sizeof(host.p_model);
-@@ -573,6 +617,12 @@
- #error Need to specify a method to get p_vendor, p_model
- #endif
-
-+#if defined(__FreeBSD__)
-+#if defined(__i386__) || defined(__amd64__)
-+ use_cpuid(*this);
-+#endif
-+#endif
-+
- ///////////// p_ncpus /////////////////
-
- // sysconf not working on OS2
-@@ -639,6 +689,13 @@
- int mem_size;
- getsysinfo( GSI_PHYSMEM, (caddr_t) &mem_size, sizeof( mem_size));
- m_nbytes = 1024.* (double)mem_size;
-+#elif defined(__FreeBSD__)
-+ unsigned int mem_size;
-+ mib[0] = CTL_HW;
-+ mib[1] = HW_PHYSMEM;
-+ len = sizeof(mem_size);
-+ sysctl(mib, 2, &mem_size, &len, NULL, 0);
-+ m_nbytes = mem_size;
- #else
- #error Need to specify a method to get memory size
- #endif
diff --git a/net/boinc-client/files/patch-fix_anonymous_platform_attach b/net/boinc-client/files/patch-fix_anonymous_platform_attach
deleted file mode 100644
index cbf5bce667d9..000000000000
--- a/net/boinc-client/files/patch-fix_anonymous_platform_attach
+++ /dev/null
@@ -1,18 +0,0 @@
---- client/cs_account.C.orig Fri Mar 3 22:34:00 2006
-+++ client/cs_account.C Wed Apr 12 10:58:15 2006
-@@ -403,7 +403,14 @@
- //
- get_project_dir(project, dir);
- sprintf(path, "%s/%s", dir, APP_INFO_FILE_NAME);
-- if (!boinc_file_exists(path)) {
-+ if (boinc_file_exists(path)) {
-+ project->anonymous_platform = true;
-+ f = fopen(path, "r");
-+ if (f) {
-+ parse_app_info(project, f);
-+ fclose(f);
-+ }
-+ } else {
- retval = remove_project_dir(*project);
- }
-
diff --git a/net/boinc-client/files/patch-lib_util.C b/net/boinc-client/files/patch-lib_util.C
deleted file mode 100644
index bbe80a0a25b2..000000000000
--- a/net/boinc-client/files/patch-lib_util.C
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/util.C.orig 2007-12-28 19:58:32.000000000 +0100
-+++ lib/util.C 2007-12-28 20:24:07.000000000 +0100
-@@ -41,6 +41,7 @@
- #include <fstream>
- #include <cctype>
- #include <sys/types.h>
-+#include <signal.h>
- #include <sys/stat.h>
- #include <sys/wait.h>
- #include <fcntl.h>
diff --git a/net/boinc-client/pkg-plist b/net/boinc-client/pkg-plist
index e052f8eb1e33..adb0c31b7170 100644
--- a/net/boinc-client/pkg-plist
+++ b/net/boinc-client/pkg-plist
@@ -9,13 +9,12 @@ include/BOINC/boinc_win.h
include/BOINC/boinc_zip.h
include/BOINC/common_defs.h
include/BOINC/config.h
+include/BOINC/coproc.h
include/BOINC/crypt.h
include/BOINC/diagnostics.h
include/BOINC/error_numbers.h
include/BOINC/filesys.h
-include/BOINC/graphics_api.h
-include/BOINC/graphics_impl.h
-include/BOINC/graphics_lib.h
+include/BOINC/graphics2.h
include/BOINC/gui_rpc_client.h
include/BOINC/gutil.h
include/BOINC/hostinfo.h
@@ -31,9 +30,6 @@ include/BOINC/version.h
include/BOINC/util.h
lib/libboinc.a
lib/libboinc_api.a
-%%BOINC_GUI%%lib/libboinc_graphics_api.a
-%%BOINC_GUI%%lib/libboinc_graphics_impl.a
-%%BOINC_GUI%%lib/libboinc_graphics_lib.a
%%BOINC_GUI%%lib/libboinc_graphics2.a
lib/libboinc_zip.a
@dirrm include/BOINC