aboutsummaryrefslogtreecommitdiffstats
path: root/net/bounce/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-12-30 12:31:42 +0800
committerobrien <obrien@FreeBSD.org>1998-12-30 12:31:42 +0800
commit7b2f437b593ca7faaa26907bf985c34facda3696 (patch)
tree84048907442663b215223edea47c25006f4310d5 /net/bounce/Makefile
parent9232be38c59333ae5297984b054cfc25758c2412 (diff)
downloadfreebsd-ports-gnome-7b2f437b593ca7faaa26907bf985c34facda3696.tar.gz
freebsd-ports-gnome-7b2f437b593ca7faaa26907bf985c34facda3696.tar.zst
freebsd-ports-gnome-7b2f437b593ca7faaa26907bf985c34facda3696.zip
A little program to bounce tcp connections to another machine/port.
Diffstat (limited to 'net/bounce/Makefile')
-rw-r--r--net/bounce/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/bounce/Makefile b/net/bounce/Makefile
new file mode 100644
index 000000000000..1cf3b71fdf91
--- /dev/null
+++ b/net/bounce/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: bounce
+# Version required: 1.0
+# Date created: Mon Dec 23, 1998
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= bounce
+PKGNAME= bounce-1.0
+CATEGORIES= net security
+MASTER_SITES= http://www.eleves.ens.fr:8080/home/espel/ \
+ http://www.freebsd.org/~obrien/Distfiles/
+DISTFILES= ${DISTNAME}.c
+
+MAINTAINER= obrien@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${DISTNAME} ${DISTNAME}.c)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/libexec
+
+.include <bsd.port.mk>