aboutsummaryrefslogtreecommitdiffstats
path: root/net/btqueue/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-05 20:54:40 +0800
committerpav <pav@FreeBSD.org>2004-06-05 20:54:40 +0800
commitbdb20e14fee82fe5c6a363b1a31aad5d8c0e27bd (patch)
tree80e73be7baa3ec7c96dfddf6b4e1fa3e4d3fa723 /net/btqueue/Makefile
parent307fd69c677603c459e35ace381ff1dc8fbca265 (diff)
downloadfreebsd-ports-gnome-bdb20e14fee82fe5c6a363b1a31aad5d8c0e27bd.tar.gz
freebsd-ports-gnome-bdb20e14fee82fe5c6a363b1a31aad5d8c0e27bd.tar.zst
freebsd-ports-gnome-bdb20e14fee82fe5c6a363b1a31aad5d8c0e27bd.zip
Add btqueue, a console-based BitTorrent client with queuing
functionalities running on top of BitTornado. PR: ports/67567 Submitted by: Stefan Walter <sw@gegenunendlich.de>
Diffstat (limited to 'net/btqueue/Makefile')
-rw-r--r--net/btqueue/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/btqueue/Makefile b/net/btqueue/Makefile
new file mode 100644
index 000000000000..1f25bbfe6adb
--- /dev/null
+++ b/net/btqueue/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: BTQueue
+# Date created: 04 Jun 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= btqueue
+PORTVERSION= 0.0.8
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= BTQueue-${PORTVERSION}
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= Alternative BitTorrent client with queuing functionality
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
+
+CONFLICTS= py??-*[Bb]it[Tt]ornado* py??-*[Bb]it[Tt]orrent*
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>