aboutsummaryrefslogtreecommitdiffstats
path: root/net/cactid
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-02-27 05:16:23 +0800
committerclement <clement@FreeBSD.org>2005-02-27 05:16:23 +0800
commit68b735a3e9fed228750ba0c8880b6b6e4b80e51b (patch)
treed968f73769eed74b368e4e8620b025203ad90840 /net/cactid
parentda1a307cb6f3080bf3041fdc4b2a9954c6e0a876 (diff)
downloadfreebsd-ports-gnome-68b735a3e9fed228750ba0c8880b6b6e4b80e51b.tar.gz
freebsd-ports-gnome-68b735a3e9fed228750ba0c8880b6b6e4b80e51b.tar.zst
freebsd-ports-gnome-68b735a3e9fed228750ba0c8880b6b6e4b80e51b.zip
- Add cactid 0.8.6d
Cactid is a poller for Cacti that primarily strives to be as fast as possible. For this reason it is written in native C, makes use of POSIX threads, and is linked directly against the net-snmp library for minmumal SNMP polling overhead. Cactid is a replacement for the default cmd.php poller so you must decide if using Cactid makes sense for your installation. WWW: http://www.cacti.net/cactid_info.php
Diffstat (limited to 'net/cactid')
-rw-r--r--net/cactid/Makefile34
-rw-r--r--net/cactid/distinfo2
-rw-r--r--net/cactid/pkg-descr8
-rw-r--r--net/cactid/pkg-plist14
4 files changed, 58 insertions, 0 deletions
diff --git a/net/cactid/Makefile b/net/cactid/Makefile
new file mode 100644
index 000000000000..00e4525a509e
--- /dev/null
+++ b/net/cactid/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cactid
+# Date created: Feb 26 2005
+# Whom: clement@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cactid
+PORTVERSION= 0.8.6.d
+CATEGORIES= net
+MASTER_SITES= http://www.cacti.net/downloads/cactid/
+DISTNAME= cacti-${PORTNAME}-0.8.6d
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A multithreaded poller for Cacti written in C
+
+LIB_DEPENDS= netsnmp.7:${PORTSDIR}/net-mgmt/net-snmp
+
+GNU_CONFIGURE= YES
+USE_MYSQL= YES
+USE_OPENSSL= YES
+USE_REINPLACE= YES
+
+post-patch:
+ @${REINPLACE_CMD} 's,%%PREFIX%%,${PREFIX},' \
+ ${WRKSRC}/cactid.h
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/cactid.conf ${EXAMPLESDIR}
+ @[ -e ${PREFIX}/etc/cactid.conf ] || \
+ ${INSTALL_DATA} ${EXAMPLESDIR}/cactid.conf ${PREFIX}/etc/
+
+.include <bsd.port.mk>
diff --git a/net/cactid/distinfo b/net/cactid/distinfo
new file mode 100644
index 000000000000..7c4d486b6094
--- /dev/null
+++ b/net/cactid/distinfo
@@ -0,0 +1,2 @@
+MD5 (cacti-cactid-0.8.6d.tar.gz) = 8fbd96cbe73af9cd3a7dc2e5de1f0a92
+SIZE (cacti-cactid-0.8.6d.tar.gz) = 115333
diff --git a/net/cactid/pkg-descr b/net/cactid/pkg-descr
new file mode 100644
index 000000000000..bf46eb143990
--- /dev/null
+++ b/net/cactid/pkg-descr
@@ -0,0 +1,8 @@
+Cactid is a poller for Cacti that primarily strives to be as fast as
+possible. For this reason it is written in native C, makes use of POSIX
+threads, and is linked directly against the net-snmp library for
+minmumal SNMP polling overhead. Cactid is a replacement for the default
+cmd.php poller so you must decide if using Cactid makes sense for your
+installation.
+
+WWW: http://www.cacti.net/cactid_info.php
diff --git a/net/cactid/pkg-plist b/net/cactid/pkg-plist
new file mode 100644
index 000000000000..79c4f4cfe306
--- /dev/null
+++ b/net/cactid/pkg-plist
@@ -0,0 +1,14 @@
+bin/cactid
+@unexec if cmp -s %D/etc/cactid.conf %D/%%EXAMPLESDIR%%/cactid.conf; then rm -f %D/etc/cactid.conf; fi
+%%EXAMPLESDIR%%/cactid.conf
+@exec [ -f %D/etc/cactid.conf ] || cp %D/%%EXAMPLESDIR%%/httpd-std.conf %D/etc/cactid.conf
+include/cactid.h
+include/common.h
+include/locks.h
+include/nft_popen.h
+include/php.h
+include/poller.h
+include/snmp.h
+include/sql.h
+include/util.h
+@dirrm %%EXAMPLESDIR%%