aboutsummaryrefslogtreecommitdiffstats
path: root/net/citrix_ica
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1999-01-05 00:26:59 +0800
committerobrien <obrien@FreeBSD.org>1999-01-05 00:26:59 +0800
commitd2e6a1c6642a912cc69aaf57c3b6562d3a519b12 (patch)
treedb232b363f0cb621039e82484c002032168f4093 /net/citrix_ica
parent1678ec34ded5b37dec3543f89c4c501799e81efe (diff)
downloadfreebsd-ports-gnome-d2e6a1c6642a912cc69aaf57c3b6562d3a519b12.tar.gz
freebsd-ports-gnome-d2e6a1c6642a912cc69aaf57c3b6562d3a519b12.tar.zst
freebsd-ports-gnome-d2e6a1c6642a912cc69aaf57c3b6562d3a519b12.zip
Change do-fetch target so automatated ``cd /usr/ports ; make fetch'' will work.
Diffstat (limited to 'net/citrix_ica')
-rw-r--r--net/citrix_ica/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 040204cafd5c..466d01f7923c 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -3,7 +3,7 @@
# Date created: 20 Sep 1998
# Whom: msmith
#
-# $Id: Makefile,v 1.3 1998/12/28 23:38:12 msmith Exp $
+# $Id: Makefile,v 1.4 1998/12/30 03:56:28 obrien Exp $
#
DISTNAME= linux
@@ -25,20 +25,11 @@ IS_INTERACTIVE= "Noisy license agreement ignores stdin"
CDIR= ${PREFIX}/lib/ICAClient
BINDIR= ${PREFIX}/bin
-do-fetch:
- @if [ ! -f ${DISTDIR}/${DISTFILES} ]; then \
- ${ECHO} "" ; \
- ${ECHO} " The source to this port may not be automatically fetched" ; \
- ${ECHO} " due to licensing restrictions. You MUST fetch the source" ; \
- ${ECHO} " manually after reading and agreeing to the license at:" ; \
- ${ECHO} "" ; \
- ${ECHO} " http://download.citrix.com/download.asp?client=LINUX" ; \
- ${ECHO} "" ; \
- ${ECHO} " Once ${DISTFILES} has been downloaded, move it to ${DISTDIR}" ; \
- ${ECHO} " and then restart this build." ; \
- ${ECHO} "" ; \
- exit 1 ; \
- fi
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE='The source to this port may not be automatically fetched due to licensing restrictions. You MUST fetch the source manually after reading and agreeing to the license at: http://download.citrix.com/download.asp?client=LINUX Once ${DISTFILES} has been downloaded, move it to ${DISTDIR} and then restart this build.'
+.endif
do-install:
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/response \
@@ -51,4 +42,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>