aboutsummaryrefslogtreecommitdiffstats
path: root/net/cphone
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2003-09-09 15:16:37 +0800
committerroger <roger@FreeBSD.org>2003-09-09 15:16:37 +0800
commit0a8955e3e774efbbb2a0fe8ecb47707ce4933627 (patch)
treed86dcbb01ab92e2e03ca3b10f8694a624da22bbf /net/cphone
parent6b14eda109e9645abd881c0130866d5aa12ecf86 (diff)
downloadfreebsd-ports-gnome-0a8955e3e774efbbb2a0fe8ecb47707ce4933627.tar.gz
freebsd-ports-gnome-0a8955e3e774efbbb2a0fe8ecb47707ce4933627.tar.zst
freebsd-ports-gnome-0a8955e3e774efbbb2a0fe8ecb47707ce4933627.zip
reactivate cphone
Diffstat (limited to 'net/cphone')
-rw-r--r--net/cphone/Makefile35
-rw-r--r--net/cphone/distinfo1
-rw-r--r--net/cphone/pkg-descr12
-rw-r--r--net/cphone/pkg-plist1
4 files changed, 49 insertions, 0 deletions
diff --git a/net/cphone/Makefile b/net/cphone/Makefile
new file mode 100644
index 000000000000..d629ab481d7b
--- /dev/null
+++ b/net/cphone/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: cphone
+# Date created: Thu May 24 15:50:00 BST 2000
+# Whom: Roger Hardiman <roger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cphone
+PORTVERSION= 0.3.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= roger@FreeBSD.org
+COMMENT= H323 Video Conferencing Program which uses QT
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
+
+NOCLEANDEPENDS= yes
+
+USE_BZIP2= yes
+USE_BISON= yes
+USE_QT_VER= 3
+USE_GMAKE= yes
+ALL_TARGET= optnoshared
+MAKE_ENV= QTDIR=${X11BASE} \
+ PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/cphone ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/cphone/distinfo b/net/cphone/distinfo
new file mode 100644
index 000000000000..78555cbe0321
--- /dev/null
+++ b/net/cphone/distinfo
@@ -0,0 +1 @@
+MD5 (cphone-0.3.1.tar.bz2) = 7574cc0aae961561792bd0b8d17ae933
diff --git a/net/cphone/pkg-descr b/net/cphone/pkg-descr
new file mode 100644
index 000000000000..208fbbd40952
--- /dev/null
+++ b/net/cphone/pkg-descr
@@ -0,0 +1,12 @@
+CPhone is a H323 Video Conferencing Program compatible with other
+H323 video conferencing programs including Microsoft NetMeeting,
+OhPhone and GnomeMeeting.
+
+CPhone supports full duplex audio and bi-directional video.
+It requires a full duplex sound card for audio support
+and a Bt848/878 based video card (using the bktr driver) is required if you
+want to send video.
+
+It uses the OpenH323 and PWLib libraries (see ports/net/openh323)
+
+WWW: http://cphone.sourceforge.net/
diff --git a/net/cphone/pkg-plist b/net/cphone/pkg-plist
new file mode 100644
index 000000000000..908a0035b5d7
--- /dev/null
+++ b/net/cphone/pkg-plist
@@ -0,0 +1 @@
+bin/cphone