aboutsummaryrefslogtreecommitdiffstats
path: root/net/cvsup
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>2005-03-26 05:38:06 +0800
committerjdp <jdp@FreeBSD.org>2005-03-26 05:38:06 +0800
commitce1e2fd785f01d1a4a6515b6c38c6d4e1feb6e2b (patch)
tree01014aeffa21ba21823039da4951abaf4af4c367 /net/cvsup
parent9ca30c2b2f61234d8690aed38b7b7082667c85fc (diff)
downloadfreebsd-ports-gnome-ce1e2fd785f01d1a4a6515b6c38c6d4e1feb6e2b.tar.gz
freebsd-ports-gnome-ce1e2fd785f01d1a4a6515b6c38c6d4e1feb6e2b.tar.zst
freebsd-ports-gnome-ce1e2fd785f01d1a4a6515b6c38c6d4e1feb6e2b.zip
Add a patch for cvsupd to make it honor the "refuse" file for files
that are in the Attic. This solves the problem people are having where their INDEX* files are being deleted even though they have them listed in the refuse file. Since the bug is in the server, mirror sites will need to upgrade their CVSup installation in order for users to benefit from this fix. Note: I bumped PORTREVISION from 0 to 2, intentionally skipping 1. The amd64 version of this port had already bumped it to 1, and I didn't want to confuse matters by bumping the other architectures to the same revision number. Approved by: portmgr (krion)
Diffstat (limited to 'net/cvsup')
-rw-r--r--net/cvsup/Makefile2
-rw-r--r--net/cvsup/files/patch-ae43
2 files changed, 44 insertions, 1 deletions
diff --git a/net/cvsup/Makefile b/net/cvsup/Makefile
index fa7641ae8d43..1300a186f1e9 100644
--- a/net/cvsup/Makefile
+++ b/net/cvsup/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cvsup
PORTVERSION?= 16.1h
-PORTREVISION?= 0
+PORTREVISION?= 2
CATEGORIES= net devel
MASTER_SITES= ${MASTER_SITE_FREEBSD_ORG}
MASTER_SITE_SUBDIR=development/CVSup/snapshots
diff --git a/net/cvsup/files/patch-ae b/net/cvsup/files/patch-ae
new file mode 100644
index 000000000000..85462dcd5745
--- /dev/null
+++ b/net/cvsup/files/patch-ae
@@ -0,0 +1,43 @@
+Index: server/src/TreeComp.m3
+===================================================================
+RCS file: /home/cvsupcvs/cvsup/server/src/TreeComp.m3,v
+retrieving revision 1.76
+diff -u -r1.76 TreeComp.m3
+--- server/src/TreeComp.m3 4 Mar 2003 19:26:17 -0000 1.76
++++ server/src/TreeComp.m3 25 Mar 2005 19:34:43 -0000
+@@ -662,21 +662,20 @@
+ type := FileInfo.Type.Live);
+ END;
+ | CVTree.FileType.AtticFile =>
+- WITH atticPath = SupMisc.AtticName(path) DO
+- IF attr.fileType = FileAttr.FileType.File
+- AND SupMisc.IsRCS(path) THEN
+- IF m.sfr.fileFilter.test(atticPath) THEN
+- RETURN NEW(FileInfo.T,
+- name := path,
+- attr := attr,
+- type := FileInfo.Type.Dead);
+- END;
+- ELSE (* Non-RCS file in the Attic?! *)
+- WITH fullPath = SupMisc.CatPath(m.sfr.serverPrefix, atticPath)
+- DO
+- Warning(m.treeComp,
+- "Non-RCS file \"" & fullPath & "\" in Attic");
+- END;
++ IF attr.fileType = FileAttr.FileType.File
++ AND SupMisc.IsRCS(path) THEN
++ IF m.sfr.fileFilter.test(path) THEN
++ RETURN NEW(FileInfo.T,
++ name := path,
++ attr := attr,
++ type := FileInfo.Type.Dead);
++ END;
++ ELSE (* Non-RCS file in the Attic?! *)
++ WITH fullPath = SupMisc.CatPath(m.sfr.serverPrefix,
++ SupMisc.AtticName(path))
++ DO
++ Warning(m.treeComp,
++ "Non-RCS file \"" & fullPath & "\" in Attic");
+ END;
+ END;
+ | CVTree.FileType.DirUp =>