aboutsummaryrefslogtreecommitdiffstats
path: root/net/cyphesis
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2011-03-08 15:39:45 +0800
committeroliver <oliver@FreeBSD.org>2011-03-08 15:39:45 +0800
commit5dbff018f3269dccbc27617fff5ec89c9dfb3847 (patch)
tree03e9de57687cc0a2eb36213f189c8581bf91c2d9 /net/cyphesis
parentd73acbbaa7a1d8c5684e2c0468931227312c9659 (diff)
downloadfreebsd-ports-gnome-5dbff018f3269dccbc27617fff5ec89c9dfb3847.tar.gz
freebsd-ports-gnome-5dbff018f3269dccbc27617fff5ec89c9dfb3847.tar.zst
freebsd-ports-gnome-5dbff018f3269dccbc27617fff5ec89c9dfb3847.zip
undo last commit as it was a "in work" version of the Makefile
set USE_PYTHON to 2.5-2.6
Diffstat (limited to 'net/cyphesis')
-rw-r--r--net/cyphesis/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index efbef455dae2..ec84a32eb40b 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -1,3 +1,4 @@
+
# New ports collection makefile for: cyphesis
# Date created: 02 Oct 2005
# Whom: Oliver Lehmann <oliver@FreeBSD.org>
@@ -7,7 +8,7 @@
PORTNAME= cyphesis
PORTVERSION= 0.5.21
-PORTREVISION= 7
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= SF/worldforge/${PORTNAME}%20%28server%29/${PORTVERSION}
@@ -17,7 +18,7 @@ COMMENT= A server for WorldForge games
LIB_DEPENDS= Atlas-0.6.1:${PORTSDIR}/devel/atlas-devel \
varconf-1.0.6:${PORTSDIR}/devel/varconf \
wfmath-0.3.4:${PORTSDIR}/math/wfmath \
- mercator-0.3.1:${PORTSDIR}/devel/mercator \
+ mercator-0.2.8:${PORTSDIR}/devel/mercator \
skstream-0.3.5:${PORTSDIR}/net/skstream \
gcrypt.17:${PORTSDIR}/security/libgcrypt
@@ -29,7 +30,7 @@ USE_GNOME= gnomehack
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PGSQL= yes
-USE_PYTHON= 2.2-2.6
+USE_PYTHON= 2.5-2.6
CFLAGS+= -I${LOCALBASE}/include
@@ -41,12 +42,8 @@ MAN1= cyclient.1 cycmd.1 cyphesis.1 cyphesis-tools.1 cyaddrules.1 \
post-patch:
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-confbackupDATA | |g' ${WRKSRC}/data/Makefile.in
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g; \
- s|-lpython|${PTHREAD_LIBS} &|; \
- s|mercator-0\.2|mercator-0\.3|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|mercator-0\.2|mercator-0\.3|g' \
- ${WRKSRC}/client/Makefile.in
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|-lpython|${PTHREAD_LIBS} &|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|$$(datadir)/cyphesis|${DATADIR}|g'
@${REINPLACE_CMD} -e 's|/bash|/sh|' ${WRKSRC}/scripts/extract_revision.sh