aboutsummaryrefslogtreecommitdiffstats
path: root/net/datapipe/Makefile
diff options
context:
space:
mode:
authordbaker <dbaker@FreeBSD.org>2000-01-04 16:13:52 +0800
committerdbaker <dbaker@FreeBSD.org>2000-01-04 16:13:52 +0800
commit696b9d50a27e3680c82bd2a8de20014f899d8aad (patch)
treefb5f8918d7667751d384729acbb3b745f9f79cd7 /net/datapipe/Makefile
parentf35b0adc6ffffd30ca0bf71ad2f1c226dd4c7d43 (diff)
downloadfreebsd-ports-gnome-696b9d50a27e3680c82bd2a8de20014f899d8aad.tar.gz
freebsd-ports-gnome-696b9d50a27e3680c82bd2a8de20014f899d8aad.tar.zst
freebsd-ports-gnome-696b9d50a27e3680c82bd2a8de20014f899d8aad.zip
properly (i hope) import datapipe port
datapipe is a simple program that allows a listening TCP/IP port to be constructed on the machine it is running on. Any connections to that port will then be forwarded to the specified remote host and remote port.
Diffstat (limited to 'net/datapipe/Makefile')
-rw-r--r--net/datapipe/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/datapipe/Makefile b/net/datapipe/Makefile
new file mode 100644
index 000000000000..4d5a03567db6
--- /dev/null
+++ b/net/datapipe/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: datapipe
+# Version required: 1.0
+# Date created: 04 January 2000
+# Whom: Daniel Baker <dbaker@FreeBSD.org> <dbaker@cuckoo.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= datapipe-1.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.distributed.net/pub/dcti/unsupported/ \
+ http://http.distributed.net/pub/dcti/unsupported/
+
+DISTFILE= datapipe-1.0.tar.gz
+
+MAINTAINER= dbaker@FreeBSD.org
+
+do-build:
+ ${CC} -o ${WRKDIR}/${DISTNAME}/datapipe ${WRKDIR}/${DISTNAME}/datapipe.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/datapipe ${PREFIX}/bin
+
+.include <bsd.port.mk>