aboutsummaryrefslogtreecommitdiffstats
path: root/net/datapipe
diff options
context:
space:
mode:
authordbaker <dbaker@FreeBSD.org>2000-01-04 16:13:52 +0800
committerdbaker <dbaker@FreeBSD.org>2000-01-04 16:13:52 +0800
commit696b9d50a27e3680c82bd2a8de20014f899d8aad (patch)
treefb5f8918d7667751d384729acbb3b745f9f79cd7 /net/datapipe
parentf35b0adc6ffffd30ca0bf71ad2f1c226dd4c7d43 (diff)
downloadfreebsd-ports-gnome-696b9d50a27e3680c82bd2a8de20014f899d8aad.tar.gz
freebsd-ports-gnome-696b9d50a27e3680c82bd2a8de20014f899d8aad.tar.zst
freebsd-ports-gnome-696b9d50a27e3680c82bd2a8de20014f899d8aad.zip
properly (i hope) import datapipe port
datapipe is a simple program that allows a listening TCP/IP port to be constructed on the machine it is running on. Any connections to that port will then be forwarded to the specified remote host and remote port.
Diffstat (limited to 'net/datapipe')
-rw-r--r--net/datapipe/Makefile24
-rw-r--r--net/datapipe/distinfo1
-rw-r--r--net/datapipe/pkg-comment1
-rw-r--r--net/datapipe/pkg-descr11
-rw-r--r--net/datapipe/pkg-plist1
5 files changed, 38 insertions, 0 deletions
diff --git a/net/datapipe/Makefile b/net/datapipe/Makefile
new file mode 100644
index 000000000000..4d5a03567db6
--- /dev/null
+++ b/net/datapipe/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: datapipe
+# Version required: 1.0
+# Date created: 04 January 2000
+# Whom: Daniel Baker <dbaker@FreeBSD.org> <dbaker@cuckoo.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= datapipe-1.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.distributed.net/pub/dcti/unsupported/ \
+ http://http.distributed.net/pub/dcti/unsupported/
+
+DISTFILE= datapipe-1.0.tar.gz
+
+MAINTAINER= dbaker@FreeBSD.org
+
+do-build:
+ ${CC} -o ${WRKDIR}/${DISTNAME}/datapipe ${WRKDIR}/${DISTNAME}/datapipe.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/datapipe ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/datapipe/distinfo b/net/datapipe/distinfo
new file mode 100644
index 000000000000..5f2aa9ec6b6e
--- /dev/null
+++ b/net/datapipe/distinfo
@@ -0,0 +1 @@
+MD5 (datapipe-1.0.tar.gz) = 994760b4c69d2e4c35489787256e244c
diff --git a/net/datapipe/pkg-comment b/net/datapipe/pkg-comment
new file mode 100644
index 000000000000..fe4e6ccb35d6
--- /dev/null
+++ b/net/datapipe/pkg-comment
@@ -0,0 +1 @@
+A simple program to bind a local port and connect it to a remote socket
diff --git a/net/datapipe/pkg-descr b/net/datapipe/pkg-descr
new file mode 100644
index 000000000000..794c4b5276aa
--- /dev/null
+++ b/net/datapipe/pkg-descr
@@ -0,0 +1,11 @@
+datapipe.c is a simple program that allows a listening TCP/IP port to be
+constructed on the machine it is running on. Any connections to that port
+will then be forwarded to the specified remote host and remote port. This
+program can be useful for allowing your Distributed.net clients
+communicate to the outside world by running it on a gateway machine that
+has access to both the inside firewall and the outside realworld.
+
+Additionally, if you live behind a SOCKS firewall, you can compile this
+code with SOCKS support for your system and use it to act as a
+"SOCKS translator" for your Distributed.net clients. In this case,
+datapipe doesn't even need to be run on a gateway machine.
diff --git a/net/datapipe/pkg-plist b/net/datapipe/pkg-plist
new file mode 100644
index 000000000000..0d9d101528e1
--- /dev/null
+++ b/net/datapipe/pkg-plist
@@ -0,0 +1 @@
+bin/datapipe