aboutsummaryrefslogtreecommitdiffstats
path: root/net/despoof
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
committerpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
commitccd12ccd577604add511aad4ea4e71c32b3e2f06 (patch)
tree25b833c135dd7f2323045f819dc7121e621103fc /net/despoof
parente2f15954f8960a944e8d5b2c28982257d8c6e91f (diff)
downloadfreebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.gz
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.zst
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Diffstat (limited to 'net/despoof')
-rw-r--r--net/despoof/Makefile21
-rw-r--r--net/despoof/pkg-plist4
2 files changed, 19 insertions, 6 deletions
diff --git a/net/despoof/Makefile b/net/despoof/Makefile
index 347b4c01c8a3..9ad19be9b7a9 100644
--- a/net/despoof/Makefile
+++ b/net/despoof/Makefile
@@ -7,7 +7,7 @@
PORTNAME= despoof
PORTVERSION= 0.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net security
MASTER_SITES= http://www.bindview.com/Resources/RAZOR/Files/ \
${MASTER_SITE_PACKETSTORM}
@@ -17,11 +17,24 @@ EXTRACT_SUFX= .tgz
MAINTAINER= roam@FreeBSD.org
COMMENT= Command-line anti-spoofing detection utility
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-I$${LOCALBASE}/include ||; \
+ s|-L$${LOCALBASE}/lib ||; \
+ s|--defines|& --cflags|; \
+ s|libnet-config|${LIBNET_CONFIG}|; \
+ s|-lnet |`${LIBNET_CONFIG} --libs` |' \
+ ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/despoof ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/doc/despoof
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/despoof
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/net/despoof/pkg-plist b/net/despoof/pkg-plist
index 649e235a9c9b..d0a161f4f02c 100644
--- a/net/despoof/pkg-plist
+++ b/net/despoof/pkg-plist
@@ -1,3 +1,3 @@
bin/despoof
-share/doc/despoof/README
-@dirrm share/doc/despoof
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%