aboutsummaryrefslogtreecommitdiffstats
path: root/net/dhcperf
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-11-01 05:19:53 +0800
committeredwin <edwin@FreeBSD.org>2006-11-01 05:19:53 +0800
commit5353d91f7278046795dee3ee45029b0a29c41c1f (patch)
treeca2156ce6b452a49897053c81dd93240273fcb70 /net/dhcperf
parentb4b13b209c067fd1e2861d84761ef646ca7d282a (diff)
downloadfreebsd-ports-gnome-5353d91f7278046795dee3ee45029b0a29c41c1f.tar.gz
freebsd-ports-gnome-5353d91f7278046795dee3ee45029b0a29c41c1f.tar.zst
freebsd-ports-gnome-5353d91f7278046795dee3ee45029b0a29c41c1f.zip
[new port] dns/queryperf net/dhcperf replacement for dns/queryperf
DHCPerf Provides Communication Providers with Predictive Planning Tools to Scale Networks. This tool, DHCPerf, delivers accurate performance metrics of Dynamic Host Configuration Protocol (DHCP) services. These tools are easy-to-use and simulate real Internet workloads to provide the necessary insight that carriers need to plan and deploy network services. DHCPerf measures the DHCP lease assignments to client computers by ramping up lease assignment over time to determine the maximum performance profile. WWW: http://www.nominum.com/testing_tools.php PR: ports/104663 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'net/dhcperf')
-rw-r--r--net/dhcperf/Makefile47
-rw-r--r--net/dhcperf/distinfo3
-rw-r--r--net/dhcperf/pkg-descr14
3 files changed, 64 insertions, 0 deletions
diff --git a/net/dhcperf/Makefile b/net/dhcperf/Makefile
new file mode 100644
index 000000000000..c6418f664727
--- /dev/null
+++ b/net/dhcperf/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: dhcperf
+# Date created: 1 November 2006
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhcperf
+PORTVERSION= 1.0.0.0
+CATEGORIES= net benchmarks
+MASTER_SITES= ftp://ftp.nominum.com/pub/nominum/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1-freebsd-5.4-i386
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= DHCPerf delivers accurate performance metrics of Dynamic Host Configuration Protocol service
+
+ONLY_ARCHS= i386
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-1/
+
+PLIST_FILES= bin/dhcperf \
+ share/doc/dhcperf/dcsevaltutorial.pdf \
+ share/doc/dhcperf/dhcperf.pdf
+PLIST_DIRS= share/doc/dhcperf
+MAN1= dhcperf.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION}<504000
+IGNORE= requires FreeBSD 5.4 or higher
+.endif
+
+.if ${OSVERSION}>600000
+LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
+.endif
+
+post-extract:
+ ${TAR} -C ${WRKSRC} -zxvf ${WRKSRC}/dhcperf-1.0.0.0_1.tgz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr/local/nom/bin/dhcperf ${PREFIX}/bin/dhcperf
+ ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/man/man1/dhcperf.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/dhcperf
+ ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dcsevaltutorial.pdf ${PREFIX}/share/doc/dhcperf/dcsevaltutorial.pdf
+ ${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dhcperf.pdf ${PREFIX}/share/doc/dhcperf/dhcperf.pdf
+
+.include <bsd.port.post.mk>
diff --git a/net/dhcperf/distinfo b/net/dhcperf/distinfo
new file mode 100644
index 000000000000..0e80bae1c8c1
--- /dev/null
+++ b/net/dhcperf/distinfo
@@ -0,0 +1,3 @@
+MD5 (dhcperf-1.0.0.0-1-freebsd-5.4-i386.tar.gz) = c7750749ffaebc8c40391e39d5fedbef
+SHA256 (dhcperf-1.0.0.0-1-freebsd-5.4-i386.tar.gz) = 5ad2aafcaa441ba6bd3edc162e9197e3ef84953b4c85fdaa8bb99711f558cf55
+SIZE (dhcperf-1.0.0.0-1-freebsd-5.4-i386.tar.gz) = 565825
diff --git a/net/dhcperf/pkg-descr b/net/dhcperf/pkg-descr
new file mode 100644
index 000000000000..8cc819d1a8d2
--- /dev/null
+++ b/net/dhcperf/pkg-descr
@@ -0,0 +1,14 @@
+DHCPerf Provides Communication Providers with Predictive Planning
+Tools to Scale Networks.
+
+This tool, DHCPerf, delivers accurate performance metrics
+of Dynamic Host Configuration Protocol (DHCP) services. These tools
+are easy-to-use and simulate real Internet workloads to provide the
+necessary insight that carriers need to plan and deploy network
+services.
+
+DHCPerf measures the DHCP lease assignments to client computers by
+ramping up lease assignment over time to determine the maximum
+performance profile.
+
+WWW: http://www.nominum.com/testing_tools.php